Bug 1251185 - Add LibreOffice basic fonts in default install
Add LibreOffice basic fonts in default install
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
All All
unspecified Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 12:02 EDT by Bastián Díaz
Modified: 2015-08-08 03:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-08 03:59:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastián Díaz 2015-08-06 12:02:56 EDT
For some time, LO includes a basic package of fonts with LibreOffice which should be available in differents OS. In recent versions, there has been a contest to encourage users to design templates and one of the requirements is to use one of these fonts to mantain separate OS compatibility with some documents.

I think that would be a good idea to include the fonts in default install of LO or highlight them as recommended in software plugins.

The list of fonts
Caladea
Carlito
DejaVu
Gentium basic
Liberation
Libertine/Biolinum
OpenSans
PT Serif
Source Code/Sans Pro

Thanks
Comment 1 Caolan McNamara 2015-08-08 03:59:21 EDT
We've a hard requires on the Caladea/Carlito google-crosextra-caladea-fonts fonts and a hard requires on the liberation-serif-fonts fonts because both sets metrically match common msoffice fonts and I consider them vital parts of the interoperable game.

The others we don't need as strongly so there isn't a hard requires from LibreOffice on them. There is now weak dependencies in rpm but I'm reluctant to make use of them for something like that.

So from the libreoffice side of things I think we have the vital bits covered, and suggesting additional default fonts to be installed alongside libreoffice is something that could be done with comps, i.e. https://fedoraproject.org/wiki/How_to_use_and_edit_comps.xml_for_package_groups

Note You need to log in before you can comment on or make changes to this bug.