Bug 1251198 - cmake bundles kwsys
cmake bundles kwsys
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cmake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On: kwsys
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2015-08-06 13:00 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2016-01-06 13:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 13:29:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2015-08-06 13:00:41 EDT
Description of problem:
cmake bundles kwsys in Source/kwsys. It's declared a copylib by upstream (kitware.com, same as cmake), but it should be a proper shared library, as it's much too large (though partial bundling is possible) and it seems to be bundled by all projects from kitware.

This came up during the discussion of FPC ticket #555 (https://fedorahosted.org/fpc/ticket/555) and tibbs suggested you might be interested in maintaining the kwsys package.

Version-Release number of selected component (if applicable):
cmake-3.3.0-1.fc24

Additional information:

kwsys upstream is here:

http://public.kitware.com/gitweb?p=KWSys.git
Comment 1 Orion Poplawski 2015-08-13 22:16:20 EDT
This is going to be a huge undertaking.  The cmake bootstrap process is intimately tied to configuring and building the bundled kwsys code.  It's going to be a huge effort to maintain downstream patches to strip it out.
Comment 2 Rex Dieter 2015-08-13 22:20:16 EDT
I think we should try harder to get a bundling exception.  In the original request/attempt, the reporter didn't provide much argument in favor.

Lacking that, one could argue that cmake's copy of kwsys be used as the canonical copy (instead of building it independantly of cmake, and having cmake use that).
Comment 3 Orion Poplawski 2016-01-06 13:29:51 EST
In accordance with new policy, bundled libraries provides added.

Note You need to log in before you can comment on or make changes to this bug.