Bug 1251201 - Javascript bug makes tablesorter show wrong results
Javascript bug makes tablesorter show wrong results
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 13:06 EDT by Albert Flügel
Modified: 2016-07-19 16:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 16:12:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Something one should never see, if javascript worked correctly in firefox (99.04 KB, image/png)
2015-08-06 13:06 EDT, Albert Flügel
no flags Details
no-repro screenshot (74.17 KB, image/png)
2015-11-10 02:34 EST, Jan Horak
no flags Details

  None (edit)
Description Albert Flügel 2015-08-06 13:06:05 EDT
Created attachment 1060049 [details]
Something one should never see, if javascript worked correctly in firefox

Description of problem:
Using the tablesorter (a javascript implementation to conveniently sort and
filter tables) often filtering (especially the exact match feature) gets
screwed up and shows too few table lines.

Version-Release number of selected component (if applicable):
firefox-39.0-8
But it happens with all firefoxes i have tried, including on windows

How reproducible:
It can be verified with this page:
https://mottie.github.io/tablesorter/docs/example-pager-filtered.html
Play a bit e.g. with the columns Japanese, English and Calculus, especially
with doing an Exact match. Exact match is switched on by prefixing the
string with an equal sign (or appending). After changing the filters several
times, too few results are shown.

Steps to Reproduce:
1. Open the page https://mottie.github.io/tablesorter/docs/example-pager-filtered.html in firefox
2. Type into the filter headers and change a bit back and forth with exact match feature
3.

Actual results:
after a while, too few lines are shown (please see attached screenshot).
What can be seen there, should not happen. There should be one line
visible containing both Japanese and Calculus the value 90, as you can
easily verify opening the page and typing into both filter headers =90 .

Expected results:
Correct filtering

Additional info:
It does not happen in Chrome or Internet Exploiter, but also with
firefox on windows or older redhat or ubuntu
Comment 1 Jan Horak 2015-11-09 08:57:41 EST
Thanks for bugreport. Do you still see this issue in Firefox 42? I cannot reproduce now.
Comment 2 Albert Flügel 2015-11-09 14:12:06 EST
Yes i still see it with firefox 42. Please go to this link,
https://mottie.github.io/tablesorter/docs/example-pager-filtered.html
and play with =100 in Column English, 90= in column Japanese and 90= in column Calculus. It cannot be seen instantly. Try a bit. Remove the equal sign, type it again, remove an entire fields, type it again, with or without equal sign. All of a sudden, you see nothing shown anymore, though one row should be visible.
Comment 3 Jan Horak 2015-11-10 02:34 EST
Created attachment 1092087 [details]
no-repro screenshot

Hm, I still can't reproduce it. Please try to run firefox in safe mode with addons/plugins disabled (firefox -safe-mode) or with fresh profile (firefox -P).
Comment 4 Albert Flügel 2015-11-10 15:38:16 EST
Very interesting. In safe-mode i never see the phenomenon, the hard i try, really.

Contrary to this, a fresh profile, a different account or different home directory do not help.
With a few typing in the filter entries things go wrong.
This seems weird to me as no extensions are installed (so safe mode should not change anything) and all add-ons are disabled anyway or in "ask to enable"
Comment 5 Jan Horak 2015-11-11 02:47:38 EST
Hm, maybe you have some system-wide installed addons? Please look at about:support page in Extensions section.
Comment 6 Albert Flügel 2015-11-12 15:03:02 EST
No, sorry. There's no extension listed.
Comment 7 Albert Flügel 2015-11-12 16:15:08 EST
I see the phenomenon also on an Android phone with firefox 42
Comment 8 Fedora End Of Life 2016-07-19 16:12:09 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.