Bug 1251234 - Unavailable AWS Config service causes many SNS requests
Unavailable AWS Config service causes many SNS requests
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Greg Blomquist
Jeff Teehan
ec2:cloud:event
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 14:02 EDT by Greg Blomquist
Modified: 2016-10-03 12:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 10:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: AWS


Attachments (Terms of Use)

  None (edit)
Description Greg Blomquist 2015-08-06 14:02:00 EDT
https://github.com/ManageIQ/manageiq/issues/3740

Manage IQ creates excessive SNS requests when it has Event Monitor role enabled, Amazon Cloud provider enabled but AWS Config Topic for SNS was not setup. This has potential to wipe out the 'free' 1 million SNS requests limit within a day or two.
Comment 1 Greg Blomquist 2016-02-19 16:48:41 EST
https://github.com/ManageIQ/manageiq/pull/4939
Comment 2 Jeff Teehan 2016-04-25 14:12:04 EDT
It's a little hard for me to turn off amazon temporarily, so I just left it running over the weekend to make sure there were no regressions.  I read the code changes and they look good.

I'll leave the CloudWatch SNS reports running for a while and will reopen if I see something.  If you know how to take amazon offline, please let me know.
Comment 4 errata-xmlrpc 2016-06-29 10:59:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.