Bug 1251248 - GNOME stopped suspending laptop on lid close
GNOME stopped suspending laptop on lid close
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 15:34 EDT by Oded Arbel
Modified: 2015-08-06 16:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 16:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2015-08-06 15:34:20 EDT
Description of problem:
For about a week now, GNOME did not suspend the laptop when closing the lid. 

Suspending by power button still works, as well as running `sudo pm-suspend`. The lid control looks fine, as monitoring /proc/acpi/button/lid/LID0/state shows 'open' and 'close' output as expected.

Looking into the power settings dialog, there is no longer an option to select what happens when the lid is closed.

Version-Release number of selected component (if applicable):
3.16.2

How reproducible:
Always

Steps to Reproduce:
1. Make sure laptop is on
2. Close lid

Actual results:
Nothing happens

Expected results:
Laptop should suspend

Additional info:
Looking in dconf-editor under 'org.gnome.settings-daemon.plugins.power', I don't see a 'lid-close-battery-action' setting. I do see a 'lid-close-ac-action', but it has schema or description - probably because I configured it in the past when I had the option.

I found a workaround, by running `dconf write /org/gnome/settings-daemon/plugins/power/lid-close-battery-action "'suspend'"`, the "suspend on lid close" behavior was fixed.

It looks like this functionality was removed from the schema at one point, and while the "on AC" action was set manually and was not removed, the "on Battery" action was removed because it was default.

There are a few other bugs related to suspend on laptop lid close, and some of them really look relateed. The main reason I opened a new ticket, is because all the bugs I'm going to mention below started to get into kernel and driver related investigations - which is clearly not the issue.
Poosibly related bugs:
#1249822
#1174480 (likely only comment #12)
#1244435
#1249363
Comment 1 Oded Arbel 2015-08-06 16:07:57 EDT
Ok, this bug report is broken - it confuses settings from older GNOME, and I no longer can reproduce the workaround I claimed to have. I'm sorry for troubling you and I'll continue to investigate.

Note You need to log in before you can comment on or make changes to this bug.