Bug 1251254 - Black screen on ARM while waiting for sddm
Black screen on ARM while waiting for sddm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
23
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2015-08-06 16:01 EDT by Paul Whalen
Modified: 2015-10-13 09:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:59:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2015-08-06 16:01:58 EDT
Description of problem:

Booting KDE on arm, sddm fails to present a login screen, displaying only a black screen with an 'X' mouse cursor. 

[root@bpi ~]# systemctl status sddm -l
��● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2015-08-06 13:18:50 EDT; 50min left
     Docs: man:sddm(1)
           man:sddm.conf(5)
 Main PID: 1557 (sddm)
   CGroup: /system.slice/sddm.service
           ��├��─1557 /usr/bin/sddm
           ��└��─1560 /usr/libexec/Xorg :0 -auth /var/run/sddm/:0 -nolisten tcp -background none -noreset vt1

Aug 06 13:18:50 bpi.friendly-neighbours.net systemd[1]: Started Simple Desktop Display Manager.
Aug 06 13:18:50 bpi.friendly-neighbours.net systemd[1]: Starting Simple Desktop Display Manager...
Aug 06 13:18:52 bpi.friendly-neighbours.net sddm-helper[1566]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)


From audit.log:
type=ANOM_ABEND msg=audit(18059.922:490): auid=4294967295 uid=989 gid=985 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 pid=1217 comm="sddm-greeter" exe="/usr/bin/sddm-greeter" sig=11

Version:

sddm-0.10.0-6.fc23.armv7hl
Comment 1 Rex Dieter 2015-08-08 11:48:55 EDT
Something apparently regressed... if this worked on f22, did it (work on f22)?
Comment 2 Paul Whalen 2015-10-13 09:59:57 EDT
closing, this is working again in f23 tc1.

Note You need to log in before you can comment on or make changes to this bug.