Bug 1251255 - Avoid unbound workqueues on isolated CPUs for realtime profiles.
Avoid unbound workqueues on isolated CPUs for realtime profiles.
Status: CLOSED DUPLICATE of bug 1259043
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned (Show other bugs)
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Jaroslav Škarvada
Depends On:
  Show dependency treegraph
Reported: 2015-08-06 16:11 EDT by Daniel Bristot de Oliveira
Modified: 2015-11-11 09:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-11 09:27:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Bristot de Oliveira 2015-08-06 16:11:21 EDT
Description of problem:
On RHEL-7.2 (and on v4.2 mainline kernel as well) it is possible to change the CPU affinity for unbound workqueue threads.

As it helps to reduce the load/jitter on isolated CPUs, it would be nice
to set the non-isolated CPUs as the cpumask for these threads on realtime
related profiles.

Version-Release number of selected component (if applicable):
tuned for RHEL-7.2

How reproducible:
Not applicable

Steps to Reproduce:
1. Not applicable

Actual results:
cpumask on /sys/devices/virtual/workqueue/cpumask is all CPUs.

Expected results:
cpumask on /sys/devices/virtual/workqueue/cpumask set to non-isolated

Additional info:
Comment 2 Jaroslav Škarvada 2015-11-11 09:27:09 EST
Closing as dupe of bug 1259043 and continuing to track the issue in bug 1259043.
It's fixed there in the 'relatime' profile which is the base for other realtime profiles.

*** This bug has been marked as a duplicate of bug 1259043 ***

Note You need to log in before you can comment on or make changes to this bug.