Bug 1251265 - Gnome3 two finger scrolling no longer works
Gnome3 two finger scrolling no longer works
Status: CLOSED DUPLICATE of bug 1235175
Product: Fedora
Classification: Fedora
Component: libinput (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-08-06 16:47 EDT by somethingsome2000+redhat
Modified: 2015-08-06 22:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-08-06 22:42:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
touchpad recording (15.29 KB, text/plain)
2015-08-06 21:47 EDT, somethingsome2000+redhat
no flags Details
xinput list-props (913 bytes, text/plain)
2015-08-06 21:48 EDT, somethingsome2000+redhat
no flags Details
evemu description (3.14 KB, text/plain)
2015-08-06 21:49 EDT, somethingsome2000+redhat
no flags Details

  None (edit)
Description somethingsome2000+redhat 2015-08-06 16:47:49 EDT
Description of problem:
two-finger scrolling in Gnome3 is broken unless launched with wayland.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Launch gnome3 on X
2. Attempt to scroll using trackpad

Actual results:
Two-finger scrolling does not work. The checkbox setting is also greyed out in
the mouse settings. This is not the case when gnome3 is launched with wayland

Expected results:
Scroll works

Additional info:
Comment 1 somethingsome2000+redhat 2015-08-06 16:51:22 EDT
Just to clarify, scrolling also does not work under wayland even though the
setting is togglable.
Comment 2 Peter Hutterer 2015-08-06 17:19:02 EDT
pls attach an evemu-describe output and the xinput list-props output for the device, and the other things in
Comment 3 somethingsome2000+redhat 2015-08-06 21:47:08 EDT
Created attachment 1060140 [details]
touchpad recording
Comment 4 somethingsome2000+redhat 2015-08-06 21:48:15 EDT
Created attachment 1060141 [details]
xinput list-props
Comment 5 somethingsome2000+redhat 2015-08-06 21:49:13 EDT
Created attachment 1060142 [details]
evemu description
Comment 6 somethingsome2000+redhat 2015-08-06 21:55:12 EDT

Additional information:
The cursor is completely stationary when attempting two-finger scroll. Libinput
knows I'm trying to do something _other_ than move the cursor.
Comment 7 Peter Hutterer 2015-08-06 22:42:26 EDT
oh, this on is a synaptics semi-mt device. we had to disable 2fg scrolling there because it was too jumpy, but libinput 0.21 (in updates-testing) has that fixed and should work fine again.

*** This bug has been marked as a duplicate of bug 1235175 ***

Note You need to log in before you can comment on or make changes to this bug.