Bug 125127 - Add updfstab.conf.default entry for hotplug of SimpleTech USB FlashDrive
Add updfstab.conf.default entry for hotplug of SimpleTech USB FlashDrive
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-06-02 17:34 EDT by Victor Semizarov
Modified: 2014-03-16 22:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-07 18:40:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Victor Semizarov 2004-06-02 17:34:09 EDT
Description of problem:
When I insert my 128MB SimpleTech USB FlashDrive memory stick
usb-storage loads but no /etc/fstab entry
is added via updfstab because of a missing entry in

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert memory stick into usb jack
Actual results:
/var/log/messages shows that USB Mass Storage is found,
usb-storage is visible via lsmod, lsusb shows the device,
but /etc/fstab entry does not appear

Expected results:
following entry in /etc/fstab:
/dev/sda1               /mnt/memstick           auto   
noauto,owner,kudzu 0 0

Additional info:

I tried to add fstab entry manually. It worked, but when I removed the
entry disappeared, i.e. updfstab worked only for "remove", not for "add".
Calling updfstab manually did not help either, i.e. updfstab did not
recognize device.
To find out actual device info, I did:
  # scsi_unique_id /dev/sda
  model: Generic USB SD Reader
  page83: No page83 information found.

Then applied the patch as follows:
--- /etc/updfstab.conf.default  2004-05-06 03:44:33.000000000 +0400
+++ /etc/updfstab.conf.default.patched  2004-06-03 00:50:03.421420000
@@ -42,6 +42,7 @@
 device memstick {
     partition 1
     match   hd MSC
+    match   hd "Generic USB SD Reader"

Now manual run of updfstab found device after hotplugging.
However, it did not happen automatically on 'add', fstab wipeout on
removals worked fine :)

I applied following patch:
--- /etc/hotplug/usb.agent      2004-05-04 02:05:18.000000000 +0400
+++ /etc/hotplug/usb.agent.patched      2004-06-03 00:51:59.540767176
@@ -432,6 +432,10 @@
        debug_mesg "... no modules for $LABEL"
        exit 2
+    if [ -x /usr/sbin/updfstab ]; then
+        /usr/sbin/updfstab
+    fi

(this is end of 'add' case entry).

After that everything was OK. But trying to open memory stick on GNOME
nautilus poped up dialog "only root can mount /dev/sda....."
If updfstab could add entries with "user" or "users" option it would work,
but updfstab can only add entries with "owner" option, so I wanted the
devices to become mine upon logon. So I applied following patch:

--- /etc/security/console.perms 2004-04-14 19:09:41.000000000 +0400
+++ /etc/security/console.perms.patched 2004-06-02 23:24:52.377416792
@@ -33,7 +33,7 @@
 <scanner>=/dev/scanner /dev/usb/scanner*
 <camera>=/mnt/camera* /dev/usb/dc2xx* /dev/usb/mdc800*
+<memstick>=/dev/sda* /dev/sdb* /dev/sdc* /mnt/memstick*

After that everything is OK and I propose these patches as a solution.
Do I need to cross-post this bug for abovementioned components ?

Comment 1 Bill Nottingham 2005-02-07 18:40:57 EST
Apologies for the delay.

As this functionality has moved to HAL, this will not be fixed at this
point for Fedora Core in updfstab.

Note You need to log in before you can comment on or make changes to this bug.