Bug 1251281 - vtk bundles libraries
vtk bundles libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2015-08-06 17:51 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2015-10-21 13:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: vtk-6.3.0-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 13:47:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2015-08-06 17:51:53 EDT
Description of problem:
vtk bundles several libraries:
* DICOMParser in Utilities/DICOMParser: upstream seems to be http://www.itk.org/Wiki/MetaIO/Documentation.
* kwsys in Utilities/KWSys: it's declared a copylib by upstream (kitware.com, same as vtk), but it should be a proper shared library, as it's much too large (though partial bundling is possible) and it seems to be bundled by all projects from kitware (http://public.kitware.com/gitweb?p=KWSys.git)
* MetaIO in Utilities/MetaIO - see http://www.itk.org/Wiki/MetaIO/Documentation and bug 1076793.
* some OpenGL headers in Utilities/ParseOGLExt/headers

This came up during the discussion of FPC ticket #555 (https://fedorahosted.org/fpc/ticket/555).

Version-Release number of selected component (if applicable):
vtk-6.2.0-8.fc24
Comment 1 Orion Poplawski 2015-08-21 16:51:15 EDT
kwsys bundling has been noted in vtk-6.2.0-9.fc24

Upstream tickets for MetaIO filed:
https://issues.itk.org/jira/browse/ITK-3375
http://www.vtk.org/Bug/view.php?id=15668
Comment 2 Orion Poplawski 2015-10-21 13:47:09 EDT
Bundled libraries noted.

Note You need to log in before you can comment on or make changes to this bug.