Bug 1251289 - paraview bundles libraries
paraview bundles libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
http://www.paraview.org/Bug/view.php?...
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2015-08-06 18:57 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2016-02-26 16:59 EST (History)
2 users (show)

See Also:
Fixed In Version: paraview-5.0.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 16:59:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2015-08-06 18:57:46 EDT
Description of problem:
Paraview bundles:

Plugins/Nektar: It seems to have been bundled since 3.12: http://www.paraview.org/Bug/print_bug_page.php?bug_id=12286 ,
upstream seems to be here: http://wwwf.imperial.ac.uk/ssherw/spectralhp/nektar/downloads/unix/ or maybe here: http://www.nektar.info/ .
Nektar plugin itself bundles:
Plugins/Nektar/Hlib: src subdir seems to contain a lot of non-free code (Copyright notice: This code shall not be replicated or used without the permission of the author.)
Plugins/Nektar/Veclib
Plugins/Nektar/metis (packaged in Fedora already)

Plugins/PointSprite/Qvis: is actually VisIt, though upstream website is showing 403 error now. The Internet Archive has a version from 2014: https://web.archive.org/web/20140627022904/https://wci.llnl.gov/codes/visit/ . Download links are still alive and show it's actually maintained: http://portal.nersc.gov/project/visit/releases/ . Latest release 2.9.2 is from 15th of June this year.

Plugins/SciberQuestToolKit: it seems to contain a lot of non-free code (opyright 2012 SciberQuest Inc.) and itself bundles eigen (Plugins/SciberQuestToolKit/eigen-3.0.3), which is already packaged in Fedora. I'm not sure where SciberQuestToolKit upstream is.

ThirdParty/IceT: http://icet.sandia.gov/
ThirdParty/QtTesting: https://github.com/Kitware/QtTesting/
ThirdParty/protobuf: packaged in Fedora (already unbundled)
ThirdParty/pugixml: packaged in Fedora (already unbundled)
ThirdParty/pygments: packaged in Fedora

Version-Release number of selected component (if applicable):
4.3.1-2.fc22
Comment 1 Dominik 'Rathann' Mierzejewski 2015-08-06 18:59:12 EDT
Setting FE-Legal blocker due to possible non-free code distribution (Plugins/Nektar/Hlib and Plugins/SciberQuestToolKit).
Comment 2 Dominik 'Rathann' Mierzejewski 2015-08-06 19:02:03 EDT
VisIt seems to be bundled here as well: Utilities/VisItBridge/Library
Comment 3 Dominik 'Rathann' Mierzejewski 2015-08-06 19:10:46 EDT
More bundled stuff:

Web/Applications/Parallel/www/js/jquery.backstretch.min.js: http://srobbin.com/jquery-plugins/backstretch/

Web/Python/paraview/web/_argparse.py: python-2.7(?) argparse module

Web/Widgets/NVCharts/paraview.nv.lineChart.js: based on NVD3 (http://nvd3.org)

Also, VTK and everything bundled there, but that's tracked under bug 697842.
Comment 4 Tom "spot" Callaway 2015-08-10 13:28:46 EDT
Orion, do you have thoughts on how you want to tackle this?  The non-free stuff is a pretty big issue and I'd like to resolve it before 23 is GA.
Comment 5 Orion Poplawski 2015-08-10 22:24:51 EDT
Nektar should be trivial to remove as it is already disabled.  I should also be able to disable the SciberQuestToolKit plugin without much trouble.  I'm assuming I need to remove those files from the tarball and upload a sanitized one?

The other complicating issue is that paraview is FTBFS at the moment due to protobuf incompatibilities.
Comment 6 Orion Poplawski 2015-08-10 22:25:48 EDT
File report upstream: http://www.paraview.org/Bug/view.php?id=15634
Comment 7 Orion Poplawski 2015-09-14 23:26:37 EDT
Nektar was removed upstream in 4.4.0.

Upstream is in the process of confirming BSD license for SciberQuestCode.

That's all of the legal issues, right?
Comment 8 Tom "spot" Callaway 2015-09-28 11:11:21 EDT
I believe so. Lifting FE-Legal.
Comment 9 Jan Kurik 2016-02-24 08:35:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.