This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251322 - op start timeout too short for httpd pacemaker resource
op start timeout too short for httpd pacemaker resource
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
Director
Unspecified Unspecified
high Severity medium
: y2
: Installer
Assigned To: Jason Guiditta
Shai Revivo
: ZStream
Depends On:
Blocks: track-osp6-osp7
  Show dependency treegraph
 
Reported: 2015-08-06 21:23 EDT by Lars Kellogg-Stedman
Modified: 2016-05-20 11:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-20 11:09:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2015-08-06 21:23:51 EDT
With a Staypuft deployed Pacemaker configuration, we have:

# pcs resource show horizon-clone
 Clone: horizon-clone
  Meta Attrs: interleave=true 
  Resource: horizon (class=systemd type=httpd)
   Attributes: start-delay=10s 
   Operations: monitor interval=60s (horizon-monitor-interval-60s)

That 10s start-delay can be too short given the pre-startup processes we run in /lib/systemd/system/httpd.service.d/openstack-dashboard.conf.  I think we should crank this up to 60s.
Comment 3 Lars Kellogg-Stedman 2015-08-07 00:36:50 EDT
So, s/start-delay/op start timeout/.  I was able to get reliable resoure startup by running:

  pcs resource op add horizon start interval=0 timeout=120
Comment 4 Mike Burns 2015-08-07 06:50:35 EDT
Moving to rhel-osp-installer components since this is staypuft.
Comment 5 Alan Pevec 2015-08-16 03:06:33 EDT
Adding Matthias to give guidance how long collectstatic + compress can take.
Comment 6 Matthias Runge 2015-08-17 01:35:23 EDT
I would even give it a little more, depending on IO speed. This compress step runs through all css/sass/less files, parsing and translating them.

On a slow machine, this still shouldn't take longer than 2 mins.
Comment 8 Jason Guiditta 2016-05-20 11:09:20 EDT
I don't believe any code fix will be made to adjust this at this point, reopen if it becomes a priority.  Otherwise, I think this is a manual step if needed for anyone on legacy setup.

Note You need to log in before you can comment on or make changes to this bug.