Bug 1251348 - Revive dead package perl-Module-Pluggable
Revive dead package perl-Module-Pluggable
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: perl-Module-Pluggable (Show other bugs)
el6
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 00:49 EDT by Tim Orling
Modified: 2015-08-10 10:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-07 02:20:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Orling 2015-08-07 00:49:23 EDT
Description of problem:
perl-Module-Pluggable is required for perl-Alien-Packages (#12742723)

Version-Release number of selected component (if applicable):
5.10-6

How reproducible:
fedpkg build

Steps to Reproduce:
1. git clone git://pkgs.fedoraproject.org/perl-Module-Pluggable.git
2. fedpkg switch-branch el6
3. fedpkg build

Actual results:
Package has been retired

Expected results:
Package builds

Additional info:
Latest version builds on koji: http://koji.fedoraproject.org/koji/taskinfo?taskID=10629863
Comment 1 Petr Pisar 2015-08-07 02:20:14 EDT
The Module::Pluggable Perl module is provided by Red Hat Enterprise Linux 6:

# repoquery --whatprovides 'perl(Module::Pluggable)' --info

Name        : perl-Module-Pluggable
Version     : 3.90
Release     : 141.el6
Architecture: x86_64
Size        : 31032
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Group       : Development/Libraries
URL         : http://www.perl.org/
License     : GPL+ or Artistic
Repository  : rhel
Summary     : Automatically give your module the ability to have plugins
Source      : perl-5.10.1-141.el6.src.rpm
Description :
Provides a simple but, hopefully, extensible way of having 'plugins' for
your module.

Therefore it cannot be distributed by EPEL.
Comment 2 Tim Orling 2015-08-10 10:49:55 EDT
perl-Alien-Packages requires perl-Module-Pluggable >= 4.5

I guess this means perl-Alien-Packages will not be made available for EPEL6.

Note You need to log in before you can comment on or make changes to this bug.