This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251352 - [abrt] tracer: paths.py:40:<module>:OSError: [Errno 25] Inappropriate ioctl for device
[abrt] tracer: paths.py:40:<module>:OSError: [Errno 25] Inappropriate ioctl f...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:75dfa3ed396c012337861096bad...
:
: 1251351 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 01:24 EDT by Tomasz Torcz
Modified: 2015-09-24 10:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.6.6-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 04:25:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.27 KB, text/plain)
2015-08-07 01:24 EDT, Tomasz Torcz
no flags Details
File: environ (176 bytes, text/plain)
2015-08-07 01:24 EDT, Tomasz Torcz
no flags Details

  None (edit)
Description Tomasz Torcz 2015-08-07 01:24:01 EDT
Version-Release number of selected component:
tracer-0.5.8-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /bin/tracer -n kmod-VirtualBox-4.0.6-300.fc22.x86_64
executable:     /bin/tracer
kernel:         4.0.6-300.fc22.x86_64
runlevel:       unknown
type:           Python
uid:            0

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/tracer/paths.py:40
#2 <module> in /usr/lib/python2.7/site-packages/tracer/resources/applications.py:22
#3 <module> in /usr/lib/python2.7/site-packages/tracer/views/default.py:3
#4 <module> in /usr/lib/python2.7/site-packages/tracer/controllers/default.py:20
#5 dispatch in /usr/lib/python2.7/site-packages/tracer/resources/router.py:54
#6 run in /usr/lib/python2.7/site-packages/tracer/main.py:42
#7 <module> in /bin/tracer:34
Comment 1 Tomasz Torcz 2015-08-07 01:24:04 EDT
Created attachment 1060177 [details]
File: backtrace
Comment 2 Tomasz Torcz 2015-08-07 01:24:05 EDT
Created attachment 1060178 [details]
File: environ
Comment 3 Jakub Kadlčík 2015-08-10 05:53:41 EDT
Hello, thank you for the feedback.

Can you please try to run

python -c "import os; print(os.path.expanduser('~' + os.getlogin()))"

which is basically paths.py:40 line from traceback.
Comment 4 Jakub Kadlčík 2015-08-10 05:57:36 EDT
More precisely, this line (according to 1251351):

python -c "import os; print(os.getlogin())"
Comment 5 Jakub Kadlčík 2015-08-10 06:01:12 EDT
*** Bug 1251351 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Kadlčík 2015-08-21 18:57:22 EDT
Modified in: 679a6de
Comment 7 Fedora Update System 2015-08-21 20:31:43 EDT
tracer-0.6.5-1.fc21 has been submitted as an update to Fedora 21. https://bugzilla.redhat.com/show_bug.cgi?id=1251352
Comment 8 Fedora Update System 2015-08-21 20:32:11 EDT
tracer-0.6.5-1.fc22 has been submitted as an update to Fedora 22. https://bugzilla.redhat.com/show_bug.cgi?id=1251352
Comment 9 Fedora Update System 2015-08-22 21:49:07 EDT
tracer-0.6.5-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13961
Comment 10 Fedora Update System 2015-08-22 21:50:03 EDT
tracer-0.6.5-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13960
Comment 11 Fedora Update System 2015-09-08 06:42:22 EDT
tracer-0.6.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15324
Comment 12 Fedora Update System 2015-09-08 06:42:32 EDT
tracer-0.6.6-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15325
Comment 13 Fedora Update System 2015-09-08 17:21:56 EDT
tracer-0.6.6-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15325
Comment 14 Fedora Update System 2015-09-08 17:25:49 EDT
tracer-0.6.6-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update tracer'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15324
Comment 15 Fedora Update System 2015-09-24 04:25:34 EDT
tracer-0.6.6-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-09-24 10:19:08 EDT
tracer-0.6.6-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.