Bug 1251355 - [RFE] Port labcontroller edit page to backbone
[RFE] Port labcontroller edit page to backbone
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 22.0
: ---
Assigned To: Roman Joost
tools-bugs
: FutureFeature, Patch
Depends On:
Blocks: 1211119 1337812
  Show dependency treegraph
 
Reported: 2015-08-07 01:32 EDT by Roman Joost
Modified: 2016-05-20 02:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 00:33:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Joost 2015-08-07 01:32:36 EDT
The lab controller page should be ported to backbone to:

1. provide a REST API
2. use the API by back bone

Functionality should be as equal to editing a lab controller and hitting save.
Comment 1 Roman Joost 2015-08-20 23:23:21 EDT
Increasing the story points since it turned out that this task is more complex for me than anticipated.
Comment 2 Roman Joost 2015-10-08 23:25:04 EDT
Moving status back to NEW and postponing the work here, since there are more important things to work on at the moment.

WIP patch is here: https://gerrit.beaker-project.org/4335
Comment 3 Roman Joost 2015-10-21 21:05:56 EDT
I'll finish this off now to get it out of the way. Otherwise the patch will become to old to make any use of it anymore.
Comment 4 Roman Joost 2015-11-02 20:21:17 EST
Patch available on gerrit:

https://gerrit.beaker-project.org/#/c/4335/
Comment 7 Dan Callaghan 2016-01-14 00:33:28 EST
Beaker 22.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.