Bug 125138 - Error enabling swap device hda2: Invalid argument
Error enabling swap device hda2: Invalid argument
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 21:02 EDT by Mike Pullen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 13:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Pullen 2004-06-02 21:02:55 EDT
Description of problem:
Downloaded FC2 from bittorrent (four CDs) and tried to upgrade FC1.
Immediately after answering the "Upgrade an Existing Installation" 
page, I receive the error above, requiring a reboot (only option 
allowed).  I found a note about LCD monitors requiring the boot 
option "nofb", same result. Trying graphical install mode.

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Boot from Fedora Core 2, CD1
2. give all default answers 
3. error occurs every time at the same point: "Upgrade an existing 
installion
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2004-06-02 23:46:31 EDT
Does your swap partition still exist as /dev/hda2?  What does your
/etc/fstab contain?
Comment 2 Mike Pullen 2004-06-03 07:48:18 EDT
Yes, the partition still exists as I can reboot into Fedora Core 1 
without complaint.  Fstab contains:

LABEL=/SYS              /            ext3  defaults              1 1
LABEL=/boot             /boot        ext3  defaults              1 2
none                    /dev/pts   devpts  gid=5,mode=620        0 0
none                    /proc        proc  defaults              0 0
none                    /dev/shm    tmpfs  defaults              0 0
/dev/hda3               swap          swap defaults              0 0
/dev/fd0                /mnt/floppy   auto noauto,owner,kudzu    0 0
/dev/cdrom         /mnt/cdrom  udf,iso9660 noauto,owner,kudzu,ro 0 0

I don't understand why anaconda thinks the swap partition is hda2.  
HDA2 should be the /boot partition.  HDA4 contains everything else.
__________
Mike P
Comment 3 Mike Pullen 2004-06-13 18:07:39 EDT
Any progress on this investigation?

Fedora Core 1 is running with this configuration right now and quite 
happy about these settings.  Any reason that Core 2 would not like 
this arrangement?  

The system has one physical disk drive with a simplified partition 
structure:
/dev/hda
   hda1     1      13      102   ext3
   hda2    14     268     2000   ext3
   hda3   269     395      996   linux-swap
   hda4   396    4863    35048   Extended
     hda5 396    4863    35048   ext3

_______
Mike P
Comment 4 Dean Brettle 2004-06-25 23:09:57 EDT
I had the same problem and found that reinitializing my swap
partitions and swap files fixed the problem.  Specifically, for each
swap partition/file, I did:

swapoff <path>
mkswap <path>
swapon <path>

The mkswap man page indicates that there are 2 styles of swap areas. 
I guessing that mine were the "old" style until I reinitialized them
with mkswap.  Anaconda should probably detect this situation and
upgrade the swap areas on the fly.
Comment 5 Mike Pullen 2004-06-27 15:22:36 EDT
Ok, this didn't change the result at all.

I followed the steps above to reinitialize the swap space and 
forced /dev/hda3 to be -v1 (new format) with the command
'mkswap -v1 /dev/hda3'.

Anaconda still thinks that the /dev/hda2 is the swap and (rightly) 
claims it is not initialized.  Hda2 contains the boot partition data.

The exact error message is "Error enabling swap device hda2: Invalid 
argument". It only give one possible avenue out of this, reboot the 
system. The swap partition is in hda3. I listed the single disk 
structure and the fstab contents in previous replies.

The swap partition was originally created by Red Hat Linux 9 and 
upgraded about a year ago to Fedora Core 1 with subsequent patches 
from Red Hat patch service to keep it fully up to date.

Is there a big difference between Core 1 with patches and Core 2?
______
Mike P
Comment 6 Gary W. Sherwin 2004-07-18 14:17:18 EDT
I am experiencing the same problem:

I have:
  hde1     1    13   102   ext3
  hde2    14  9664 75705   ext3
  hde3  9665  9729   510   linux-swap

I get the error:

  Error enabling swap device hdg3.  No such file or directory

  NOTE:  I do not have a device hdgX.  I have hd<b>e</b>

My installation is Core 1 and also fully updated.

I have tried noprobe, text, C3boot-2.iso.  Everything stops at
exactly the same place.

Gary W. Sherwin


Comment 7 Gary W. Sherwin 2004-07-21 19:16:31 EDT
Well, Now I am feeling realy stupid.  All that was wrong, was the
incorrect hdg3 enty in fstab.  Fixing that corrected the problem!

Thank you so much for your assistance
Comment 8 Mike Pullen 2004-07-29 07:45:53 EDT
Hey, Jeremy Katz!  Any progress or updates on this issue to report?  
Can anyone offer anything new to investigate or try?  Anaconde still 
thinks the swap partition is in the wrong place (see previous entries 
in this bug report series).  Any advice or tricks would be greatly 
appreciated!
___________
Mike P
Comment 9 Mike Pullen 2004-09-12 08:56:58 EDT
Jeremy, I can not upgrade my Fedora Core 1 system to Fedora Core 2 
because the Anaconde installer complains that the swap partition is 
not initialized.  It thinks the swap partition is on the wrong place 
still.  I have reinitialized the swap partition to the the new 
format, inspected the fstab file and checked the disk partitions 
carefully using Linux and non-Linux tools.  I need your help in 
further diagnosis of this issue.

Please provide me with an small list of additional things to check, 
reset, or investigate.  I would appreciate any guidance toward 
remedying this.  I can't complete the upgrade to Fedora Core 2 as it 
stands now.

Thanks for your help with with.
___________
Mike Pullen
Comment 10 Mike Pullen 2004-09-19 12:11:33 EDT
You can close this problem ticket now because my system crashed 
during Hurricane Ivan and corrupted the boot disk to the point it is 
not repairable.  As I have to reinstall everything from scratch, I'll 
use the opportunity to jump to Core 2.

Thanks for the suggetions and advice, even though they did not 
actually resolve the problem directly.
______
Mike P

Note You need to log in before you can comment on or make changes to this bug.