Bug 125142 - Can't build xterm with X.Org libraries
Can't build xterm with X.Org libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 22:03 EDT by Steve Snyder
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-18 18:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2004-06-02 22:03:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040120

Description of problem:
This error is seen when building binary packages from
xterm-179-6.EL.src.rpm on FC2:

creating Makefile
creating xtermcfg.h
+ make
gcc -I. -I. -DHAVE_CONFIG_H  -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/X11R6/include -Dlinux
-D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE
-D_BSD_SOURCE -D_SVID_SOURCE -DFUNCPROTO=15 -DNARROWPROTO -I.    
-DPROJECTROOT=/usr/X11R6 -DXVENDORNAME=The -DXVENDORNAMESHORT=X.Org  
-DOSMAJORVERSION=2 -DOSMINORVERSION=6  -I/usr/X11R6/include 
-D_GNU_SOURCE -march=pentium4 -O2 -pipe -fomit-frame-pointer  X.Org
Foundation -W -Wall -c ./button.c
gcc: X.Org: No such file or directory
gcc: Foundation: No such file or directory


Version-Release number of selected component (if applicable):
179-6.EL

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 with "[] Everything" package selection
2. Run "rpmbuild --rebuild xterm-179-6.EL.src.rpm"
3.
    

Actual Results:  Source files will not build because the string "X.Org
Foundation" is inserted into the compiler command line by Configure.

Expected Results:  Source files should build without error.

Additional info:

This is where the train goes off the tracks.  From file
~/BUILD/xterm-179/config.log:

configure:5850: checking for X FreeType libraries
configure:5872: gcc -o conftest -march=pentium4 -O2 -pipe
-fomit-frame-pointer  X.Org Foundation  -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/X11R6/include -Dlinux
-D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE
-D_BSD_SOURCE -D_SVID_SOURCE -DFUNCPROTO=15 -DNARROWPROTO -I.
-DSCROLLBAR_RIGHT -DOPT_WIDE_CHARS -DOPT_LUIT_PROG -DXRENDERFONT
-DPROJECTROOT=/usr/X11R6 -DXVENDORNAME=The -DXVENDORNAMESHORT=X.Org
-DUSE_UTEMPTER -DUSE_TTY_GROUP -DOSMAJORVERSION=2 -DOSMINORVERSION=6 
-I/usr/X11R6/include  -D_GNU_SOURCE   -L/usr/X11R6/lib conftest.c
-lXft -lfreetype -lXrender -lXrender -lXaw -lXmu -lXext -lXt  -lSM
-lICE -lX11 -lnsl -lutempter  -ltermcap  1>&5
gcc: X.Org: No such file or directory
gcc: Foundation: No such file or directory
configure: failed program was:
#line 5860 "configure"
Comment 1 Thomas E. Dickey 2004-06-03 19:11:02 EDT
This is (mostly) fixed in xterm patch #190.  I have a small
fix which will be in #191 (when I'm done testing the rest of
it, this week).
Comment 2 Thomas E. Dickey 2004-06-09 19:10:01 EDT
I committed #191 on Sunday.
Comment 3 Mike A. Harris 2004-06-11 14:42:48 EDT
Thanks Thomas, I'll update xterm in rawhide soon.
Comment 4 Mike A. Harris 2004-06-18 18:16:32 EDT
xterm updated to 191 in rawhide now.

Thomas:  Do you have a small patch for this?  If so, I can add it
to our 179 packages too.

TIA
Comment 5 Thomas E. Dickey 2004-06-18 18:29:16 EDT
not really - the change was to macros in aclocal.m4 which iirc
had been fairly stable, but it changed several places.  Do a
diff and look at CF_ADD_CFLAGS, CF_IMAKE_CFLAGS (I recall there
were 3-4 macros modified, but those are the main ones).

Note You need to log in before you can comment on or make changes to this bug.