Bug 1251422 - Invalid -march=native for gcc on ppc/s390
Invalid -march=native for gcc on ppc/s390
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: atanks (Show other bugs)
22
ppc64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ZedoraTracker PPCTracker ARM64/F-ExcludeArch-aarch64 F-ExcludeArch-ppc64le/PPC64LETracker
  Show dependency treegraph
 
Reported: 2015-08-07 05:35 EDT by Rafael Fonseca
Modified: 2015-10-11 12:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: atanks-6.3-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-11 12:03:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch + spec changeset (1.88 KB, patch)
2015-09-24 05:51 EDT, Marcin Juszkiewicz
no flags Details | Diff

  None (edit)
Description Rafael Fonseca 2015-08-07 05:35:33 EDT
Description of problem: atanks fails to build on ppc and s390 because '-march=native' is not a valid flag for gcc on these platforms.


Version-Release number of selected component (if applicable): 6.3-1


How reproducible: try to koji-build atanks on ppc64/s390x


Actual results: g++ fails with the following errors:

PPC: # make
Compiling obj/network.o
/usr/lib64/ccache/g++ -DDATA_DIR=\"/usr/share/games/atanks\" -DLINUX -DVERSION=\"6.3\" -DNETWORK -I/usr/include -march=native -Wall -Wextra -Wpedantic -std=c++11 -pthread -O2 -o obj/network.o -c src/network.cpp
g++: error: unrecognized command line option ‘-march=native’
Makefile:284: recipe for target 'obj/network.o' failed
make: *** [obj/network.o] Error 1

S390x: # g++ -march=native
g++: error: unrecognized argument in option ‘-march=native’
g++: note: valid arguments to ‘-march=’ are: g5 g6 z10 z196 z9-109 z9-ec z900 z990 zEC12
g++: fatal error: no input files
compilation terminated.
Comment 1 Marcin Juszkiewicz 2015-09-24 05:50:47 EDT
also on aarch64
Comment 2 Marcin Juszkiewicz 2015-09-24 05:51 EDT
Created attachment 1076426 [details]
patch + spec changeset

This fixes issue.
Comment 3 Marcin Juszkiewicz 2015-10-01 07:15:20 EDT
pushed to rawhide
Comment 4 Fedora Update System 2015-10-08 06:07:30 EDT
atanks-6.3-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-69de455c28
Comment 5 Fedora Update System 2015-10-09 09:56:03 EDT
atanks-6.3-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update atanks'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-69de455c28
Comment 6 Fedora Update System 2015-10-11 12:03:26 EDT
atanks-6.3-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.