Bug 1251467 - ec sequentializes all reads, limiting read throughtput
ec sequentializes all reads, limiting read throughtput
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavi Hernandez
: Triaged
Depends On: 1245689
Blocks: glusterfs-3.7.7
  Show dependency treegraph
 
Reported: 2015-08-07 07:53 EDT by Xavi Hernandez
Modified: 2016-04-19 03:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1245689
Environment:
Last Closed: 2016-02-15 02:38:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavi Hernandez 2015-08-07 07:53:30 EDT
+++ This bug was initially created as a clone of Bug #1245689 +++

Description of problem:

ec needs to issue locks for reads, so it uses the same management functions used for writes. This means that reads are sent one by one in sequence. Since reads do not touch any state of the file, there could be multiple read requests running at the same time, improving read performance.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-07-22 17:12:09 CEST ---

REVIEW: http://review.gluster.org/11742 (cluster/ec: Allow read fops to be processed in parallel) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Anand Avati on 2015-07-29 05:17:15 CEST ---

REVIEW: http://review.gluster.org/11742 (cluster/ec: Allow read fops to be processed in parallel) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Anand Avati on 2015-07-29 09:38:38 CEST ---

REVIEW: http://review.gluster.org/11742 (cluster/ec: Allow read fops to be processed in parallel) posted (#3) for review on master by Xavier Hernandez (xhernandez@datalab.es)

--- Additional comment from Anand Avati on 2015-08-06 13:26:34 CEST ---

REVIEW: http://review.gluster.org/11742 (cluster/ec: Allow read fops to be processed in parallel) posted (#4) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 1 Kaushal 2015-10-28 08:28:46 EDT
This bug could not be fixed in time for glusterfs-3.7.4 or glusterfs-3.7.5. This is now being tracked for being fixed in glusterfs-3.7.6.
Comment 2 Vijay Bellur 2015-10-28 09:40:58 EDT
REVIEW: http://review.gluster.org/12447 (cluster/ec: Allow read fops to be processed in parallel) posted (#2) for review on release-3.7 by Xavier Hernandez (xhernandez@datalab.es)
Comment 3 Raghavendra Talur 2015-11-08 15:27:26 EST
This bug could not be fixed in time for glusterfs-3.7.6.
This is now being tracked for being fixed in glusterfs-3.7.7.
Comment 4 Vijay Bellur 2015-11-23 07:09:10 EST
REVIEW: http://review.gluster.org/12447 (cluster/ec: Allow read fops to be processed in parallel) posted (#3) for review on release-3.7 by Xavier Hernandez (xhernandez@datalab.es)
Comment 5 Vijay Bellur 2015-11-24 22:03:21 EST
COMMIT: http://review.gluster.org/12447 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 69e74432ee1ab29ba7caf483450997a95920b729
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Wed Jul 22 17:08:02 2015 +0200

    cluster/ec: Allow read fops to be processed in parallel
    
    Currently ec only sends a single read request at a time for a given
    inode. Since reads do not interfere between them, this patch allows
    multiple concurrent read requests to be sent in parallel.
    
    This is a backport of these patches:
    
    > Change-Id: If853430482a71767823f39ea70ff89797019d46b
    > BUG: 1245689
    > Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    > Reviewed-on: http://review.gluster.org/11742
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >
    > Change-Id: I6042129f09082497b80782b5704a52c35c78f44d
    > BUG: 1276031
    > Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    
    Change-Id: I1b1146d1fd1828b12bfc566cd76e5ea110f8909b
    BUG: 1251467
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: http://review.gluster.org/12447
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 6 Kaushal 2016-04-19 03:46:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.