Bug 1251469 - [RFE] Add support for more fence agents
[RFE] Add support for more fence agents
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Martin Perina
Pavel Stehlik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 08:00 EDT by Jiri Belka
Modified: 2016-03-03 09:20 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 09:20:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2015-08-07 08:00:26 EDT
Description of problem:

I suppose we could support more fence agents, ideally to have also an user-defined fence agent so one could cook its own fencing agent.

It seems to me that at least fence-agents-rhevm, fence-agents-vmware-soap and fence-virt are good candicates for support.

with rhevm fence agent one would fence virtual hosts, same with two others (ok, I'm not sure if KVM would be available under ESXi).

(There was a question about soft fence agent on ovirt users list.)

engine=# select * from vdc_options where option_name = 'VdsFenceType' and version = '3.6';
-[ RECORD 1 ]+--------------------------------------------------------------------------------------------------
option_id    | 629
option_name  | VdsFenceType
option_value | apc,apc_snmp,bladecenter,cisco_ucs,drac5,drac7,eps,hpblade,ilo,ilo2,ilo3,ilo4,ipmilan,rsa,rsb,wti
version      | 3.6

# rpm -qR fence-agents-all | grep ^fence | nl
     1  fence-agents-apc
     2  fence-agents-apc-snmp
     3  fence-agents-bladecenter
     4  fence-agents-brocade
     5  fence-agents-cisco-mds
     6  fence-agents-cisco-ucs
     7  fence-agents-compute
     8  fence-agents-drac5
     9  fence-agents-eaton-snmp
    10  fence-agents-emerson
    11  fence-agents-eps
    12  fence-agents-hpblade
    13  fence-agents-ibmblade
    14  fence-agents-ifmib
    15  fence-agents-ilo2
    16  fence-agents-ilo-moonshot
    17  fence-agents-ilo-mp
    18  fence-agents-ilo-ssh
    19  fence-agents-intelmodular
    20  fence-agents-ipdu
    21  fence-agents-ipmilan
    22  fence-agents-mpath
    23  fence-agents-kdump
    24  fence-agents-rhevm
    25  fence-agents-rsa
    26  fence-agents-rsb
    27  fence-agents-scsi
    28  fence-agents-vmware-soap
    29  fence-agents-wti
    30  fence-virt

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Oved Ourfali 2015-08-09 08:03:51 EDT
We added the basic ones. We usually add more on demand.
Targeting for 4.0 for consideration.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-19 06:58:36 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Oved Ourfali 2015-12-31 03:27:16 EST
Martin - let's go over the list, and consider what to do as part of the fencing work planned for 4.0.
Comment 4 Yaniv Kaul 2016-03-03 09:20:13 EST
Closing - as there are specific bugs to add specific agents. 
We add by demand (and by what we / the community / the customers  can test.

Note You need to log in before you can comment on or make changes to this bug.