Bug 125152 - Cannot mount [partition]: File or Directory not found
Cannot mount [partition]: File or Directory not found
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 02:02 EDT by Matt Sage
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 14:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Sage 2004-06-03 02:02:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When upgrading from RH9, the FC2 installer fails and reports that it
cannot mount /home on /dev/sda15: File or directory not found.

The problem lies in that /dev/sda15 is not defined so anaconda cannot
use it to mount the home directory.

My temporary workaround was to comment out the partition relating to
/dev/sda15 from /etc/fstab, then do the upgrade and finally restore
/etc/fstab.  That worked well for /home but this obviously would not
be possible if something more useful was on /dev/sda15.

I have replicated this bug in FC1 too and as I can't find a bug report
I figure I must be the only crazy idiot with 15 partitions on a disc! :-)


Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always

Steps to Reproduce:
1. Have RH9 system with 15 partitions on /dev/sda
2. Run FC1 installer and choose upgrade

    

Additional info:
Comment 1 Jeremy Katz 2004-10-07 14:45:20 EDT
The kernel doesn't allow having more than 14 partitions on a SCSI disk
due to the allocated minors for each disk.

Note You need to log in before you can comment on or make changes to this bug.