Bug 1251533 - [Docs] [Director] Update of overcloud deploy command with Ceph
[Docs] [Director] Update of overcloud deploy command with Ceph
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: async
: Director
Assigned To: Dan Macpherson
Martin Lopes
: Documentation, ZStream
Depends On: 1247585
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 11:29 EDT by Jiri Stransky
Modified: 2016-01-11 05:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 05:11:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Stransky 2015-08-07 11:29:03 EDT
When fixes for bug 1247585 get released, a simultaneous change to the documentation should be made.

The change is described in this comment:
https://bugzilla.redhat.com/show_bug.cgi?id=1247585#c6

and it's also described in the doc text of that same BZ.


Specifically, deploying via `openstack overcloud deploy` done with `--templates` parameter and some Ceph nodes (having `--ceph-storage-count` greater than 0) will need to get an additional parameter:

-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml

An update will be needed at least in section "6.3.8. Creating the Advanced Overcloud", where the deployment command is affected by this change.


Additional info:
----------------

The environment file above is meant for users to customize what storage backends are used in OpenStack services. The file defaults to using Ceph for Cinder, Glance and Nova ephemeral storage, so if this is what user wants, they can just reference the file directly. If they want some other combination of storage backends, they would copy the file somewhere and customize it, and then pass the customized version to `openstack overcloud deploy` instead. Here's how the file looks inside currently:

https://github.com/openstack/tripleo-heat-templates/blob/e96c087509193d5ad63caa3014977a2baf0db0d3/environments/storage-environment.yaml


Please let me know if more info is needed. Thanks :)
Comment 5 jliberma@redhat.com 2015-08-07 13:27:49 EDT
full command example:

openstack overcloud deploy -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/network-environment.yaml --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph --ntp-server 10.16.255.2 --control-scale 3 --compute-scale 4 --ceph-storage-scale 4 --block-storage-scale 0 --swift-storage-scale 0 -t 90 --templates -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml
Comment 6 jliberma@redhat.com 2015-08-07 13:48:30 EDT
If you deploy ceph with tuskar or use templates but omit the -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml parameter you will see the following error in in undercloud heat-engine.log:

2015-08-07 01:01:09.691 17016 INFO heat.engine.stack [-] Stack CREATE FAILED (overcloud): Resource CREATE failed: ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Resource CREATE failed: ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Resource CREATE failed: Error: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6"

Correct deployment command syntax:

openstack overcloud deploy -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/network-environment.yaml --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph --ntp-server 10.16.255.2 --control-scale 3 --compute-scale 4 --ceph-storage-scale 4 --block-storage-scale 0 --swift-storage-scale 0 -t 90 --templates -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml

Related bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=1247585
https://bugzilla.redhat.com/show_bug.cgi?id=1236167
Comment 8 Dan Macpherson 2015-08-10 11:16:20 EDT
Docs updated, but still need to make a note aout adding storage config through tuskar.
Comment 9 Dan Macpherson 2015-08-10 11:43:22 EDT
Discussed with jistr. For the moment, we won't be documenting Ceph deployment with tuskar plans. The recommended/supported way is through Heat templates.
Comment 10 Andrew Dahms 2015-08-12 19:36:15 EDT
Assigning Martin as the QA contact.

Martin - could you review the changes made above?
Comment 11 Martin Lopes 2015-08-30 19:28:20 EDT
Completed peer review. Looks good to me.
Comment 12 Andrew Dahms 2016-01-11 05:11:24 EST
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.