Bug 1251537 - AttributeError: 'MDBiosRaidArrayDevice' object has no attribute '_currentSize'
AttributeError: 'MDBiosRaidArrayDevice' object has no attribute '_currentSize'
Status: CLOSED DUPLICATE of bug 1245191
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:acaec4729bbbc53250e4ada1ee7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 11:38 EDT by Ian Pilcher
Modified: 2015-08-10 02:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 02:59:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (559.41 KB, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: anaconda.log (8.21 KB, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: dnf.log (145 bytes, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: environ (494 bytes, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: lsblk_output (13.98 KB, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: nmcli_dev_list (2.16 KB, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: program.log (61.16 KB, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: storage.log (369.24 KB, text/plain)
2015-08-07 11:38 EDT, Ian Pilcher
no flags Details
File: syslog (106.11 KB, text/plain)
2015-08-07 11:39 EDT, Ian Pilcher
no flags Details
File: ifcfg.log (7.03 KB, text/plain)
2015-08-07 11:39 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Ian Pilcher 2015-08-07 11:38:49 EDT
Description of problem:
Boot Fedora 23 Alpha RC2 server netinst on system with Intel software RAID (IMSM), with partitions on RAID device.

Version-Release number of selected component:
anaconda-23.17-1

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 604, in currentSize
    if self._currentSize == Size(0):
  File "/usr/lib/python3.4/site-packages/blivet/devices/md.py", line 681, in _addParent
    self._size = self.currentSize
  File "/usr/lib/python3.4/site-packages/blivet/devices/lib.py", line 156, in append
    self.appendfunc(y)
  File "/usr/lib/python3.4/site-packages/blivet/devices/device.py", line 153, in _setParentList
    self._parents.append(parent)
  File "/usr/lib/python3.4/site-packages/blivet/devices/device.py", line 89, in __init__
    self.parents = parents or []
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 107, in __init__
    super(StorageDevice, self).__init__(name, parents=parents)
  File "/usr/lib/python3.4/site-packages/blivet/devices/container.py", line 63, in __init__
    super(ContainerDevice, self).__init__(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/devices/md.py", line 112, in __init__
    sysfsPath=sysfsPath)
  File "/usr/lib/python3.4/site-packages/blivet/devices/md.py", line 631, in __init__
    super(MDBiosRaidArrayDevice, self).__init__(name, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 568, in addUdevDiskDevice
    sysfsPath=sysfs_path, **kwargs)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 721, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1660, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python3.4/site-packages/blivet/populator.py", line 1597, in populate
    self._populate()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 554, in populate
    self._populator.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 279, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1123, in storageInitialize
    storage.reset()
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'MDBiosRaidArrayDevice' object has no attribute '_currentSize'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-23_A_T2-x86_64 rd.driver.blacklist=bcache
dnf.rpm.log:    Aug 07 10:36:31 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc3.git4.1.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Ian Pilcher 2015-08-07 11:38:52 EDT
Created attachment 1060409 [details]
File: anaconda-tb
Comment 2 Ian Pilcher 2015-08-07 11:38:53 EDT
Created attachment 1060410 [details]
File: anaconda.log
Comment 3 Ian Pilcher 2015-08-07 11:38:54 EDT
Created attachment 1060411 [details]
File: dnf.log
Comment 4 Ian Pilcher 2015-08-07 11:38:54 EDT
Created attachment 1060412 [details]
File: environ
Comment 5 Ian Pilcher 2015-08-07 11:38:55 EDT
Created attachment 1060413 [details]
File: lsblk_output
Comment 6 Ian Pilcher 2015-08-07 11:38:56 EDT
Created attachment 1060414 [details]
File: nmcli_dev_list
Comment 7 Ian Pilcher 2015-08-07 11:38:56 EDT
Created attachment 1060415 [details]
File: os_info
Comment 8 Ian Pilcher 2015-08-07 11:38:57 EDT
Created attachment 1060416 [details]
File: program.log
Comment 9 Ian Pilcher 2015-08-07 11:38:59 EDT
Created attachment 1060417 [details]
File: storage.log
Comment 10 Ian Pilcher 2015-08-07 11:39:00 EDT
Created attachment 1060418 [details]
File: syslog
Comment 11 Ian Pilcher 2015-08-07 11:39:01 EDT
Created attachment 1060419 [details]
File: ifcfg.log
Comment 12 Vojtech Trefny 2015-08-10 02:59:07 EDT

*** This bug has been marked as a duplicate of bug 1245191 ***

Note You need to log in before you can comment on or make changes to this bug.