Bug 125155 - 4 HDDs need 4 restarts in order to become visible
4 HDDs need 4 restarts in order to become visible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-03 02:49 EDT by Dragos Moinescu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 03:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dragos Moinescu 2004-06-03 02:49:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I have installed Fedora Core 2 on the following system:
1. Athlon XP 2500+
2. 1GB RAM
3. 4xMaxtor 6Y160P0
4. Asus A7N8X-X ACPI BIOS Rev007
5. SiI 0680 ATA/133 Medley RAID Controller Bios Version 3.2.10

Because there is no driver for this raid controller, I have chosen
software raid (3 in RAID 1, 1 as boot hdd).
After I do a reboot from OS (reboot command or CTRL-ALT-DEL) my raid
controller cannot view all hard disks. In fact it sees none. I must
press restart button 4 times in order to view all the hard disks.
After each restart it sees one more hdd. If I press restart button in
grub (waiting to boot Fedora) there are no problems.
I have installed Fedora Core 1 on the same box with the same RAID
configuration, and there was no problem. So I cannot see if there is a
Kernel (2.6.5) problem or raidtools.
Please notice I have tried RAID 0, RAID 1 and RAID 5 and all have the
same result.



Version-Release number of selected component (if applicable):
1.00.3-8

How reproducible:
Always

Steps to Reproduce:
1. Install fedora core 2 on a box that has SiI 0680 Medley ATA/133
BIOS 3.2.10 RAID controller
2. Use software RAID
3. Reboot system using reboot
    

Actual Results:  the thing in DESCRIPTION

Expected Results:  normal reboot

Additional info:

Please notice that, in my opinion, this is a severe bug because if
this box must poweroff or reboot there must be somebody pushing the
restart button 4 times so the OS can start.
Comment 1 Doug Ledford 2004-06-03 02:54:21 EDT
Switching component to kernel.  This sounds like a problem with the
kernel ide shutdown code.  The kernel, after all commands have been
flushed to a device, then powers the device down in the 2.6 kernel
series.  I'm guessing that the controller in question doesn't spin the
drives back up and needs the reset button stuff to work.  I'm guessing
that actually powering the system down instead, which causes all the
drives to spin up on power up would work just fine.  In any case, this
bug properly belongs to the owner of the Fedora kernel package, not
raidtools.
Comment 2 Dragos Moinescu 2004-06-03 04:22:35 EDT
You are very right. I tested once again with poweroff, instead of
reboot. It worked with no problems.
Can you tell me if this is going to be solved as soon as posible?
thank you
Comment 3 Barry K. Nathan 2004-06-08 22:00:38 EDT
Try the test kernels here:
http://people.redhat.com/arjanv/2.6/RPMS.kernel/
Comment 4 Barry K. Nathan 2004-07-14 11:15:08 EDT
Dragos, have you tried a recent Fedora Core 2 update kernel? (The
latest right now is 2.6.6-1.435.2.3.) Let us know if that fixes the
problem.
Comment 5 Dragos Moinescu 2004-08-02 03:02:31 EDT
hello, sorry for the late comment.
it works like a charm. the problem is solved.
thank you!
Comment 6 Barry K. Nathan 2004-08-02 03:18:28 EDT
In that case, you should close (resolve) the bug, perhaps as "ERRATA".
Comment 7 Dragos Moinescu 2004-08-02 03:20:22 EDT
thanx once again

Note You need to log in before you can comment on or make changes to this bug.