Bug 1251553 - Winsync setup fails with unexpected error
Winsync setup fails with unexpected error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 12:12 EDT by Tomas Babej
Modified: 2016-05-05 00:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipa-4.2.0-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Babej 2015-08-07 12:12:56 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5188

When setting up a winsync agreement between IPA and AD, IPA fails with the following unexpected error:

{{{
$ sudo ipa-replica-manage connect -p blablabla --winsync --binddn cn=Administrator,cn=Users,dc=ad,dc=test --bindpw Secret123456 --passsync Secret123456 --cacert /home/tbabej/ad.test.root.cer advm.ad.test -v -f
unexpected error: non-generic 'NotFound' needs format=None; got format='Replication agreement for advm.ad.test not found'
}}}

How to reproduce:
1. Attempt to setup winsync replication agreement between IPA and AD
Comment 1 Tomas Babej 2015-08-07 12:16:00 EDT
Fixed upstream.
master:
* 5df48d74a0b473f80f728c83b41d7660398a11a4
ipa-4-2:
* b09800509a9fe577931f8914b11761f753863444
Comment 5 errata-xmlrpc 2015-11-19 07:05:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.