Bug 1251560 - openjdk 1.8.0 alternative is changed to 1.7.0 when a 1.8.0 update is applied.
Summary: openjdk 1.8.0 alternative is changed to 1.7.0 when a 1.8.0 update is applied.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk
Version: 6.8
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: Lukáš Zachar
URL:
Whiteboard:
: 1173503 (view as bug list)
Depends On:
Blocks: 1172231 1271375 1254198 1336545
TreeView+ depends on / blocked
 
Reported: 2015-08-07 17:27 UTC by Chris Williams
Modified: 2019-11-14 06:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1254198 1336545 (view as bug list)
Environment:
Last Closed: 2016-05-10 21:04:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0816 normal SHIPPED_LIVE java-1.8.0-openjdk bug fix and enhancement update 2016-05-10 22:39:37 UTC

Description Chris Williams 2015-08-07 17:27:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:

Install openjdk 1.7.0 and 1.8.0
Set alternative to 1.8.0
Update 1.8.0 package

Before install:
[root@localhost ~]# alternatives --display java
java - status is manual.
 link currently points to /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.51-1.b16.el6_7.x86_64/jre/bin/java
/usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java - priority 170079


After Install:
[root@localhost ~]# alternatives --display java
java - status is auto.
 link currently points to /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java

Actual results:
Alternative is changed to 1.7.0.

Expected results:
alternative conitues to link to 1.8.0.

Additional info:
This issue was spun off form https://bugzilla.redhat.com/show_bug.cgi?id=1217177

Comment 2 jiri vanek 2015-08-10 12:44:04 UTC
*** Bug 1173503 has been marked as a duplicate of this bug. ***

Comment 3 jiri vanek 2015-08-17 12:09:06 UTC
Fixed like this:
http://pkgs.devel.redhat.com/cgit/rpms/java-1.8.0-openjdk/commit/?id=e2709783d7d892acc9df019de97386e4d06a8be3
and built:
https://brewweb.devel.redhat.com/buildinfo?buildID=452472

I  DON'T recommend this as bugfix for 6.7 Z stream, because:
 - https://bugzilla.redhat.com/show_bug.cgi?id=1217177#c49 is fixing the symptomps
 - change in priority handling is much bigger change then it looks.

Comment 14 jiri vanek 2016-03-01 14:39:02 UTC
For record, part of this bugfix was
http://pkgs.devel.redhat.com/cgit/rpms/java-1.8.0-openjdk/commit/?h=rhel-6.8&id=e2709783d7d892acc9df019de97386e4d06a8be3

That means taht priority of openjdk8 is now highest of all jdks in rhel

Comment 18 errata-xmlrpc 2016-05-10 21:04:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0816.html


Note You need to log in before you can comment on or make changes to this bug.