Bug 1251568 - python-testtools should Requires: python-traceback2
python-testtools should Requires: python-traceback2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-testtools (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 14:30 EDT by Jerry James
Modified: 2016-07-05 04:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-testtools-1.8.0-5.fc24 python-testtools-1.8.0-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-18 14:45:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2015-08-07 14:30:10 EDT
Description of problem:
I'm trying to build subunit again now that python-testtools has been updated to 1.8.0, but the %check script is failing like this:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/testtools/run.py", line 267, in <module>
    main(sys.argv, sys.stdout)
  File "/usr/lib/python2.7/site-packages/testtools/run.py", line 264, in main
    stdout=stdout)
  File "/usr/lib/python2.7/site-packages/testtools/run.py", line 187, in __init__
    self.runTests()
  File "/usr/lib/python2.7/site-packages/testtools/run.py", line 221, in runTests
    self.result = testRunner.run(self.test)
  File "/usr/lib/python2.7/site-packages/testtools/run.py", line 107, in run
    return test.run(result)
  File "/usr/lib/python2.7/site-packages/unittest2/suite.py", line 126, in run
    test(result)
  File "/usr/lib64/python2.7/unittest/suite.py", line 70, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib64/python2.7/unittest/suite.py", line 108, in run
    test(result)
  File "/usr/lib64/python2.7/unittest/suite.py", line 70, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib64/python2.7/unittest/suite.py", line 108, in run
    test(result)
  File "/usr/lib64/python2.7/unittest/suite.py", line 70, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib64/python2.7/unittest/suite.py", line 108, in run
    test(result)
  File "/usr/lib64/python2.7/unittest/suite.py", line 70, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib64/python2.7/unittest/suite.py", line 108, in run
    test(result)
  File "/usr/lib/python2.7/site-packages/unittest2/case.py", line 649, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 606, in run
    return run_test.run(result)
  File "/usr/lib/python2.7/site-packages/testtools/runtest.py", line 80, in run
    return self._run_one(actual_result)
  File "/usr/lib/python2.7/site-packages/testtools/runtest.py", line 94, in _run_one
    return self._run_prepared_result(ExtendedToOriginalDecorator(result))
  File "/usr/lib/python2.7/site-packages/testtools/runtest.py", line 108, in _run_prepared_result
    self._run_core()
  File "/usr/lib/python2.7/site-packages/testtools/runtest.py", line 144, in _run_core
    self.case._run_test_method, self.result):
  File "/usr/lib/python2.7/site-packages/testtools/runtest.py", line 193, in _run_user
    return self._got_user_exception(sys.exc_info())
  File "/usr/lib/python2.7/site-packages/testtools/runtest.py", line 213, in _got_user_exception
    self.case.onException(exc_info, tb_label=tb_label)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 556, in onException
    self._report_traceback(exc_info, tb_label=tb_label)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 592, in _report_traceback
    self, '__testtools_tb_locals__', False)))
  File "/usr/lib/python2.7/site-packages/testtools/content.py", line 204, in __init__
    stack_lines = list(traceback.TracebackException(exctype, value, tb,
AttributeError: 'NoneType' object has no attribute 'TracebackException'

Looking at the code shows that the object with value None is a variable named "traceback" that is supposed to point to the traceback2 module, but since there is no Requires on python-traceback2, it has value None instead.

Version-Release number of selected component (if applicable):
python-testtools-1.8.0-2.fc24

How reproducible:
Always

Steps to Reproduce:
1. Try to build the subunit package in mock; see bug 1249714
2.
3.

Actual results:
Python-testtools throws an internal exception.

Expected results:
Python-testtools should be reporting on the exception my package threw instead.

Additional info:
Comment 1 Jerry James 2015-10-23 11:06:43 EDT
Ping.
Comment 2 Jan Kurik 2016-02-24 08:36:01 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Jerry James 2016-06-03 11:54:25 EDT
Ping.
Comment 4 Michel Alexandre Salim 2016-06-03 13:45:15 EDT
Apologies for the delay; fix on the way
Comment 5 Fedora Update System 2016-06-03 13:56:57 EDT
python-testtools-1.8.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0c0df7966d
Comment 6 Fedora Update System 2016-06-03 13:57:09 EDT
python-testtools-1.8.0-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a7970f869
Comment 7 Jerry James 2016-06-03 15:41:12 EDT
(In reply to Michel Alexandre Salim from comment #4)
> Apologies for the delay; fix on the way

No worries.  Thanks much for fixing it!
Comment 8 Fedora Update System 2016-06-04 14:25:42 EDT
python-testtools-1.8.0-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a7970f869
Comment 9 Fedora Update System 2016-06-04 23:58:05 EDT
python-testtools-1.8.0-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0c0df7966d
Comment 10 Fedora Update System 2016-06-18 14:45:13 EDT
python-testtools-1.8.0-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-07-05 04:26:27 EDT
python-testtools-1.8.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.