Bug 1251571 - Undercloud default neutron quotas too low
Undercloud default neutron quotas too low
Status: CLOSED DUPLICATE of bug 1243121
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z1
: Director
Assigned To: James Slagle
yeylon@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 14:44 EDT by jliberma@redhat.com
Modified: 2016-04-18 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 15:04:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jliberma@redhat.com 2015-08-07 14:44:09 EDT
Description of problem:

A small overcloud deployment that follows our recommendations for configuring network irolation (6 networks) exceeds default neutron port settings.

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch

How reproducible:

Steps to Reproduce:
1. Deploy undercloud
2. Configure network iso with 6 recommended VLANs
3. Deploy overcloud of 11 or more physical servers

Example:

openstack overcloud deploy -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/network-environment.yaml --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph --ntp-server 10.16.255.2 --control-scale 3 --compute-scale 4 --ceph-storage-scale 4 --block-storage-scale 0 --swift-storage-scale 0 -t 90 --templates -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml

Actual results:

overcloud deploy command fails with errors:

ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Resource CREATE failed: ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Resource CREATE failed: ResourceUnknownStatus: Resource failed - Unknown status FAILED due to "Resource CREATE failed: OverQuotaClient: Quota exceeded for resources: ['port']"""

Expected results:

Additional info:

Workaround:

Prior to depoying overcloud:

[stack@rhos0 ~]$ neutron quota-update --port 100
+---------------------+-------+
| Field               | Value |
+---------------------+-------+
| network             | 10    |
| port                | 100   |
| security_group      | 10    |
| security_group_rule | 100   |
| subnet              | 10    |
+---------------------+-------+

[stack@rhos0 ~]$ neutron quota-show
+---------------------+-------+
| Field               | Value |
+---------------------+-------+
| network             | 10    |
| port                | 100   |
| security_group      | 10    |
| security_group_rule | 100   |
| subnet              | 10    |
+---------------------+-------+

(deploy)

[stack@rhos0 ~]$ neutron port-list | grep -v "\-\-\-\-" | wc -l
54
Comment 3 Ben Nemec 2015-08-11 15:04:54 EDT

*** This bug has been marked as a duplicate of bug 1243121 ***

Note You need to log in before you can comment on or make changes to this bug.