Bug 125159 - kdebase builds with debug info
Summary: kdebase builds with debug info
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-03 08:08 UTC by Ben Smith
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-18 12:09:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
head of rpmbuild output (49.38 KB, text/plain)
2004-06-03 08:15 UTC, Ben Smith
no flags Details
tail of rpmbuild output (41.43 KB, text/plain)
2004-06-03 08:15 UTC, Ben Smith
no flags Details

Description Ben Smith 2004-06-03 08:08:37 UTC
Description of problem:
Despite indications that it should be built *without* debug info by
default, kdebase has debug info when built from src.rpm.

Version-Release number of selected component (if applicable):
kdebase-3.2.2-4.src.rpm

How reproducible:
very

Steps to Reproduce:
rpmbuild -bb --clean --target=i686 kdebase.spec
  
Actual results:
kdebase gets built with debug-info (97 meg package)

Expected results:
kdebase shouldn't have debug info (i386 pkg is 22 megs)

Additional info:
Although the spec file has '%define debug 0' at the beginning and it
looks like --disable-debug is passed to ./configure, it's ignored.

Also noticed there's lots of 'remember to run libtool --finish'
messages and it's never run ;)

I'm attaching a build log.

Comment 1 Ben Smith 2004-06-03 08:15:02 UTC
Created attachment 100818 [details]
head of rpmbuild output

Comment 2 Ben Smith 2004-06-03 08:15:29 UTC
Created attachment 100819 [details]
tail of rpmbuild output

Comment 3 Ben Smith 2004-06-03 08:16:20 UTC
Oops, sorry, forgot to mention I'm building on Core 1 if it makes a
difference :)

Comment 4 Ben Smith 2004-06-03 23:43:22 UTC
Tried changing '--disable-debug' in specfile to '--enable-debug=no' as
./configure --help suggests, rebuilt, no luck :(

Comment 5 Ngo Than 2004-06-04 10:12:30 UTC
it does not have to do with kdebase! If you don't want to build
package with debug info, you should have disable it in your
$HOME/.rpmmacros, for example:

%_topdir /home/than/rpm
%_sourcedir %{_topdir}/SOURCES
%_specdir   %{_topdir}/SPECS
%_srcrpmdir %{_topdir}/SRPMS
%_rpmdir %{_topdir}/RPMS
%_builddir  %{_topdir}/BUILD
%vendor     Red Hat, Inc.
%packager   Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
%debug_package %{nil}


Comment 6 Ben Smith 2004-06-05 12:22:05 UTC
Sorry but I tried that and it doesn't make a difference.  What I'm
getting, regardless, is *one* package, built with debug info.  What I
need is a package without debug info.  The error logs don't give any
clue as to what the problem could be.

I've also upgraded rpmbuild to the FC2 version in case that is the
problem.  So far it hasn't helped.

As far as I can tell this behaviour has changed since test3, which
built fine.

Comment 7 Ben Smith 2004-06-10 01:57:47 UTC
OK, I've tried so many things trying to get this to work that I'm not
*exactly* sure that this is the only solution, but the one thing that
has made a difference is to install the redhat-rpm-config package and
edit the file '/usr/lib/rpm/redhat/macros'.  I changed the variable
'%_enable_debug_packages' from '1' to '0'.  Now, instead of getting
one package with debug info, I'm getting separate -debug packages again.

In the course of testing I also upgraded several other packages, so it
might also be necessary to upgrade rpm, binutils, and libselinux to
the FC2 versions.  I'm going to continue testing on a fresh FC1
install to see if I can figure out what the necessary packages (and
missing buildreq's) are.


Comment 8 Ngo Than 2004-06-17 15:13:15 UTC
it's a rpm issue and not a bug in kdebase. 

Comment 9 Jeff Johnson 2004-06-18 12:09:02 UTC
All packages are built by Red Hat with redhat-rpm-config
installed, and setting %debug_package %{nil} works
iff redhat-rpm-config is installed.

Changing %_enable_debug_packages is an alternative
means to the same goal.

I see no other rpm problem here. Reopen if I'm wrong.


Note You need to log in before you can comment on or make changes to this bug.