Bug 1251618 - Yumex-dnf doesn't indicate installed packages properly
Yumex-dnf doesn't indicate installed packages properly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-07 19:02 EDT by Robin Laing
Modified: 2015-11-18 12:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 12:45:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
terminal display showing package is installed using RPM (45.08 KB, image/png)
2015-08-07 19:02 EDT, Robin Laing
no flags Details
Screen cap of yumex-dnf not indicating that package is installed. (35.27 KB, image/png)
2015-08-07 19:04 EDT, Robin Laing
no flags Details

  None (edit)
Description Robin Laing 2015-08-07 19:02:20 EDT
Created attachment 1060511 [details]
terminal display showing package is installed using RPM

Description of problem:
Trying to trace a constant crash with Fedora kf5-konsole, I was comparing bug reports and packages.  I tried using yumex-dnf to show me what packages are in stalled for knotify.  The only item coloured was the downgrade option.

Version-Release number of selected component (if applicable):

yumex-dnf-4.1.2-1.fc22.noarch


How reproducible:
Almost every time I have tried.



Steps to Reproduce:
1.  rpm -qa {package}
2.  open yumex-dnf
3.  search for package.

Actual results:
See attached files.
Package is installed on system but yumex-dnf doesn't show it being installed. (colour green).


Expected results:
Indicate packages that are installed.

Additional info:

Some times this is in error but there are times that it does appear to work normally.

Fully updated machine and rebooted at the time of the bug report.
Comment 1 Robin Laing 2015-08-07 19:04:49 EDT
Created attachment 1060512 [details]
Screen cap of yumex-dnf not indicating that package is installed.

This image shows that yumex-dnf isn't indicating that the kf5-knotifyconfig file is installed.  Only the downgrade is indicated by colour.
Comment 2 Robin Laing 2015-09-06 23:13:50 EDT
Today, while trying to get audio CDs to work, I found that packages that were installed were not showing up as installed still.

I tried to install the package again.  yumex-dnf didn't try to install it but didn't give me a message as to why.
Comment 3 Robin Laing 2015-09-12 16:13:13 EDT
I find that with the search options hidden, it is easy to do a search when yumex-dnf is configured only to show updates.  Old yumex would automatically search all packages and then let you click what you wanted to look for.

Need to constantly go in and change settings and do multiple searches to find what I am looking for.
Comment 4 Tim Lauridsen 2015-10-06 04:56:36 EDT
See the discussion in this upstream issue

https://github.com/timlau/yumex-dnf/issues/53
Comment 5 Tim Lauridsen 2015-11-18 12:45:33 EST
I am work on making the UI better in a future release

See.
https://github.com/timlau/yumex-dnf/issues/74

for details

I will close this bug an do the tracking in the upstream issue

Note You need to log in before you can comment on or make changes to this bug.