Bug 1251674 - Add known failures to bad_tests list
Add known failures to bad_tests list
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 11:56 EDT by Krutika Dhananjay
Modified: 2016-06-16 09:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2015-08-08 11:56:29 EDT
Description of problem:

Most of the tests listed under https://public.pad.fsfe.org/p/gluster-spurious-failures are still to be fixed.
Meanwhile, moving them to is_bad_tests list.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-08 12:01:46 EDT
REVIEW: http://review.gluster.org/11868 (tests: Add consistently failing tests to the "bad tests" list) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2015-08-10 01:54:46 EDT
COMMIT: http://review.gluster.org/11868 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 0dbc4b010d437ed7e865ff9b63744e33b3be921b
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Sat Aug 8 21:29:55 2015 +0530

    tests: Add consistently failing tests to the "bad tests" list
    
    Change-Id: Ie8f296413e012027bb335c41114cacfcde9f6904
    BUG: 1251674
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/11868
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Niels de Vos 2016-06-16 09:30:14 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.