Bug 1251679 - [abrt] qemu-system-x86: ccid_card_init(): qemu-system-x86_64 killed by SIGABRT
[abrt] qemu-system-x86: ccid_card_init(): qemu-system-x86_64 killed by SIGABRT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:d8bf63d759534cdfd7e52fac284...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 12:30 EDT by Mikhail
Modified: 2015-08-12 09:50 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 09:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (35.40 KB, text/plain)
2015-08-08 12:30 EDT, Mikhail
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-08 12:30 EDT, Mikhail
no flags Details
File: core_backtrace (19.51 KB, text/plain)
2015-08-08 12:30 EDT, Mikhail
no flags Details
File: dso_list (15.92 KB, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: environ (180 bytes, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: maps (76.89 KB, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: mountinfo (3.77 KB, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: open_fds (1.66 KB, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
File: proc_pid_status (1019 bytes, text/plain)
2015-08-08 12:31 EDT, Mikhail
no flags Details
boxes.log (3.17 KB, text/plain)
2015-08-09 14:11 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2015-08-08 12:30:48 EDT
Description of problem:
Just try start VM im gnome-boxes

Version-Release number of selected component:
qemu-system-x86-2.4.0-0.1.rc0.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/bin/qemu-system-x86_64 -machine accel=kvm -name fedora-unkno-2 -S -machine pc-i440fx-2.3,accel=kvm,usb=off -cpu Haswell-noTSX -m 2048 -realtime mlock=off -smp 8,sockets=1,cores=4,threads=2 -uuid 91bc512d-403c-4718-ba7b-b98aa183aaa2 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/home/mikhail/.config/libvirt/qemu/lib/fedora-unkno-2.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x6.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x6 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x6.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x6.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -device usb-ccid,id=ccid0 -drive file=/home/mikhail/.local/share/gnome-boxes/images/fedora-unkno-2,if=none,id=drive-virtio-disk0,format=qcow2,cache=writeback -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/home/mikhail/Downloads/Fedora-Live-Workstation-i686-23_Alpha-TC2.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=21,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:8c:c3:46,bus=pci.0,addr=0x3 -chardev spicevmc,id=charsmartcard0,name=smartcard -device ccid-card-passthru,chardev=charsmartcard0,id=smartcard0,bus=ccid0.0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -device usb-mouse,id=input1 -device usb-kbd,id=input2 -spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device AC97,id=sound0,bus=pci.0,addr=0x4 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -chardev spicevmc,id=charredir2,name=usbredir -device usb-redir,chardev=charredir2,id=redir2 -chardev spicevmc,id=charredir3,name=usbredir -device usb-redir,chardev=charredir3,id=redir3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -msg timestamp=on
crash_function: object_dynamic_cast_assert
executable:     /usr/bin/qemu-system-x86_64
global_pid:     28853
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 object_dynamic_cast_assert at qom/object.c:581
 #3 ccid_card_init at hw/usb/dev-smartcard-reader.c:1292
 #4 device_realize at hw/core/qdev.c:227
 #5 device_set_realized at hw/core/qdev.c:1046
 #6 property_set_bool at qom/object.c:1667
 #7 object_property_set_qobject at qom/qom-qobject.c:24
 #8 object_property_set_bool at qom/object.c:1015
 #9 qdev_device_add at qdev-monitor.c:599
 #10 device_init_func at vl.c:2300
 #11 qemu_opts_foreach at util/qemu-option.c:1089
Comment 1 Mikhail 2015-08-08 12:30:54 EDT
Created attachment 1060603 [details]
File: backtrace
Comment 2 Mikhail 2015-08-08 12:30:55 EDT
Created attachment 1060604 [details]
File: cgroup
Comment 3 Mikhail 2015-08-08 12:30:58 EDT
Created attachment 1060605 [details]
File: core_backtrace
Comment 4 Mikhail 2015-08-08 12:31:00 EDT
Created attachment 1060606 [details]
File: dso_list
Comment 5 Mikhail 2015-08-08 12:31:02 EDT
Created attachment 1060607 [details]
File: environ
Comment 6 Mikhail 2015-08-08 12:31:03 EDT
Created attachment 1060608 [details]
File: limits
Comment 7 Mikhail 2015-08-08 12:31:06 EDT
Created attachment 1060609 [details]
File: maps
Comment 8 Mikhail 2015-08-08 12:31:07 EDT
Created attachment 1060610 [details]
File: mountinfo
Comment 9 Mikhail 2015-08-08 12:31:09 EDT
Created attachment 1060611 [details]
File: namespaces
Comment 10 Mikhail 2015-08-08 12:31:10 EDT
Created attachment 1060612 [details]
File: open_fds
Comment 11 Mikhail 2015-08-08 12:31:11 EDT
Created attachment 1060613 [details]
File: proc_pid_status
Comment 12 Cole Robinson 2015-08-09 14:07:28 EDT
Almost 30 faf hits at time of writing

Mikhail or anyone that can reproduce, can you attach ~/.cache/libvirt/qemu/log/$vmname.log ?
Comment 13 Cole Robinson 2015-08-09 14:08:48 EDT
I wonder if this is fixed by:

commit cfda2cef3d0320d7a133600ffdb6e33547aaba8f
Author: Gerd Hoffmann <kraxel@redhat.com>
Date:   Fri Jul 17 11:34:11 2015 +0200

    usb-ccid: fix 61b4887b41b270bc837ead57bc502d904af023bb

Which is building for f23 now, as part of qemu-v2.4.0-rc4
Comment 14 Mikhail 2015-08-09 14:11:49 EDT
Created attachment 1060783 [details]
boxes.log
Comment 15 Cole Robinson 2015-08-09 14:13:20 EDT
Thanks, the error is:

hw/usb/dev-smartcard-reader.c:1292:ccid_card_init: Object 0x55be3659c000 is not an instance of type usb-device

My guess is that the referenced commit fixes it... but I just noticed my qemu-2.4.0-rc4 build failed with some dep issue in the repos, so it'll have to wait a bit
Comment 16 Cole Robinson 2015-08-11 14:27:43 EDT
qemu-2.4.0-rc4 is built and queued for f23 update, please try that and let me know if it still crashes
Comment 17 Mikhail 2015-08-12 09:08:49 EDT
Thanks, after updating qemu to version 2.4.0-rc4  the problem is disappeared.
Comment 18 Cole Robinson 2015-08-12 09:50:38 EDT
Thanks Mikhail

Note You need to log in before you can comment on or make changes to this bug.