Bug 1251697 - Alternative to esound's esd_play_file() at PulseAudio for moon-buggy
Alternative to esound's esd_play_file() at PulseAudio for moon-buggy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 17:56 EDT by Robert Scheck
Modified: 2016-05-09 08:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 15:21:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2015-08-08 17:56:01 EDT
Description of problem:
Since esound has been retired, my package moon-buggy can no longer be built.
I understand that only a few less applications depend on esound and most of
them are even able to switch to another sound implementation, but moon-buggy
is not - at least not out of the box.

I tried to use the PulseAudio example code from pacat-simple.c at
http://freedesktop.org/software/pulseaudio/doxygen/pacat-simple_8c-example.html
as an replacement, however PulseAudio is not really a good replacement. In
difference to esound the sampling details have to be specified manually and,
even more important, PulseAudio does not return while it is playing (while
esound is). Last of it causes strange interruptions for the game here, while
sounds are played.

Given that it really makes sense to switch from esound to PulseAudio, I am
looking for some support here...otherwise I will have to take esound simply;
and revive it for Fedora 23+.

Version-Release number of selected component (if applicable):
moon-buggy-1.0.51-14.fc23
esound-0.2.41-13.fc23
pulseaudio-6.0-8.fc23

Actual results:
No more esound in Fedora while moon-buggy does not support alternatives.

Expected results:
Alternative to esound's esd_play_file() at PulseAudio for moon-buggy.
Comment 1 Robert Scheck 2015-08-08 18:06:38 EDT
http://maemo.org/api_refs/5.0/5.0-final/pulseaudio/paplay_8c-example.html or
https://github.com/erikd/libsndfile/blob/master/examples/sndfile-to-text.c
are hints for solving the sampling stuff, but still leaves open the returning
while playing.
Comment 2 Yanko Kaneti 2015-08-09 07:13:45 EDT
libcanberra maybe ? http://0pointer.de/lennart/projects/libcanberra/
or some of its high level wrappers.. gsound ?
Comment 3 Jaromír Cápík 2015-08-10 07:39:39 EDT
Hi Robert.

It was not my decision to retire esound. Nobody tried to contact me and discuss that. It simply happened behind my back. What I consider sad is that someone killed the package without providing a solution for the dependent software. So, we went from freedom to a dictatorship.

Jaromir.
Comment 4 Robert Scheck 2015-08-10 08:16:49 EDT
Jaromír, my intention was not to blame you or whomever, I basically can
understand the intention behind and thus I am looking for a more future-
friendly solution anyway. While libcanberra might be suitable, it looks
a bit bloated for just playing 3 *.wav files (especially when looking to
its dependency chain).
Comment 5 Jaromír Cápík 2015-08-10 08:51:23 EDT
I admit, that esound upstream released the last version 14 years ago and that may look like the package has no right to live longer, but that is a myth. If any black box meets expectations and works like expected, then there's no need for a change. For example, an application "Hello world!" reaches the state when it doesn't need any maintenance immediately after you release it. And it doesn't stop working just because it becomes too old and has no updates for years.
But ok. That is a thing I can live with, because there might be other reasons for stripping packages from the distro. What doesn't make me happy is that a dependency is removed from the distribution before a solution for the dependent software is found. I believe a better way would be to submit bugs against the dependent software so that it could be redesigned/patched before the dependency is removed. But that didn't happen here. We rather shoot and then resolve the consequences. And if a solution is not found quickly, then the dependent package dies as well. So, it's "DO WHAT WE WANT OR DIE" policy.
Comment 6 Mamoru TASAKA 2015-09-24 11:05:22 EDT
https://lists.fedoraproject.org/pipermail/devel/2015-September/214992.html

Robert, do you want to rebuild moon-buggy without sound support for now to make this stay alive? (I think it is acceptable for now) Or moon-buggy will be removed from distro on 2015-10-12.
Comment 7 Robert Scheck 2015-09-24 11:08:04 EDT
I simply want esound back, because it was obviously removed from Fedora
without the approval of the package maintainer (Jaromír Cápík). This is
something that should not happen. Is somebody able to reverse that? Or is
a re-review needed?
Comment 8 Peter Robinson 2015-09-24 11:30:45 EDT
copr is another alternative
Comment 9 Mamoru TASAKA 2015-09-24 11:43:52 EDT
(In reply to Peter Robinson from comment #8)
> copr is another alternative

Peter, would you explain your commit
http://pkgs.fedoraproject.org/cgit/esound.git/commit/?id=241ebf78b99c2f78b47c54f66dcbaabf76a5a6ce
?
Comment 10 Robert Scheck 2015-09-24 11:46:11 EDT
(In reply to Peter Robinson from comment #8)
> copr is another alternative

For me, copr is not an alternative - because I don't want to add thousands
of community repositories like e.g. openSUSE has.
Comment 11 Robert Scheck 2015-10-02 17:21:06 EDT
Peter, may you please answer comment #9?
Comment 12 Robert Scheck 2015-10-10 20:30:56 EDT
Given Peter did not comment for 14+ days now, I raised a FESCo ticket for
this to resurrect the package: https://fedorahosted.org/fesco/ticket/1488
Comment 13 Fedora Update System 2015-10-10 20:39:22 EDT
moon-buggy-1.0.51-15.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2213d6cb34
Comment 14 Peter Robinson 2015-10-11 01:59:15 EDT
Sorry, missed the request. I've already discussed this with the esounds maintainer on IRC long ago
Comment 15 Robert Scheck 2015-10-11 08:01:07 EDT
Before or after retiring the package - and before or after comment #5? And
what was the result? Because I am still missing esound and there still is no
lightweight alternative for esd_play_file() for moon-buggy yet.
Comment 16 Fedora Update System 2015-10-11 14:49:28 EDT
moon-buggy-1.0.51-15.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update moon-buggy'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2213d6cb34
Comment 17 Fedora Update System 2015-10-12 02:26:49 EDT
moon-buggy-1.0.51-15.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-10-22 12:06:40 EDT
esound-0.2.41-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-50c582b909
Comment 19 Fedora Update System 2015-10-24 08:07:11 EDT
esound-0.2.41-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update esound'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-50c582b909
Comment 20 Fedora Update System 2015-10-25 21:40:09 EDT
moon-buggy-1.0.51-16.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-d07be08f8b
Comment 21 Fedora Update System 2015-10-26 22:18:42 EDT
moon-buggy-1.0.51-16.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update moon-buggy'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-d07be08f8b
Comment 22 Fedora Update System 2015-11-10 15:21:46 EST
moon-buggy-1.0.51-16.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2015-11-10 15:22:13 EST
esound-0.2.41-14.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.