Bug 1251709 - Update crash core file selection and error/warnings for kdump
Update crash core file selection and error/warnings for kdump
Status: CLOSED ERRATA
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: brose
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 21:56 EDT by brose
Modified: 2015-09-03 09:16 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.7.1-20150809.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 09:16:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brose 2015-08-08 21:56:09 EDT
Currently, all directories in the /var/crash directory are checked for their times, comparing them to that of the time recorded by the kdump test when it ran the first portion, prior to rebooting/panic.  The latest directory matching the naming convention to be created (taken from name that's generated when it's saved) is selected.  If that is outside of the maximum allowed time, it will error.

We are changing this in the following ways:

- When saving the crash core file, a UUID is generated and used to create the directory to look in when the second portion of the kdump test runs (upon restarting the panicked machine).  This will be unique per test run.
- We know that there should only be one directory one level down from the new UUID directory.  We will raise an error if more than one is detected.
- We no longer raise an error if the directory's created time (taken from directory name) is outside of the range previously permitted.  Instead, now, we will raise a warning and select the closest one (the only one in the directory, else it would error).
Comment 4 Brian Brock 2015-08-28 18:10:08 EDT
verified in redhat-certification-hardware-1.7.1-20150828.el7
Changed vmcore & crash directory's timestamp.  kdump test completed successfully.
Comment 6 errata-xmlrpc 2015-09-03 09:16:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1709.html

Note You need to log in before you can comment on or make changes to this bug.