Bug 1251711 - xinetd systemd service should depend on remote-fs.target
xinetd systemd service should depend on remote-fs.target
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xinetd (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 22:37 EDT by Stephen Harris
Modified: 2015-08-12 04:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 04:13:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Harris 2015-08-08 22:37:46 EDT
Description of problem:
Any service defined in /etc/xinetd.d/ that has an executable on an NFS mounted filesystem will not start up because systemd may not have completed mounting NFS filesystems at the time xinetd starts

How reproducible:
Consistently



Steps to Reproduce:
Create an entry in xinetd.d  (for example "nntp"port used here)
service nntp
{
        disable = no
        socket_type     = stream
        wait            = no
        user            = news
        flags           = IPv6
        server          = /nfs_mount/bin/executable
}

Reboot


Actual results:
Error in /var/log/messages saying that the executable isn't present and so the service is disabled

Expected results:
xinetd should wait for NFS so the executable is available

Additional info:
Fix is simple; add remote-fs.target to /usr/lib/systemd/system/xinetd.service
Comment 2 Jan Synacek 2015-08-12 04:13:58 EDT
What if you wanted to run the NFS server from xinetd? Then, it wouldn't work. You should really prefer to turn your xinetd service into a systemd service. Especially if you need dependencies.

Note You need to log in before you can comment on or make changes to this bug.