Bug 1251713 - [abrt] policycoreutils-gui: selinux_server.py:6:<module>:ImportError: No module named 'gobject'
[abrt] policycoreutils-gui: selinux_server.py:6:<module>:ImportError: No modu...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:8c2562804b20f2559db3d19f7f4...
:
Depends On:
Blocks: 1076441
  Show dependency treegraph
 
Reported: 2015-08-08 23:12 EDT by Pinkie Pie
Modified: 2015-09-02 02:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 02:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (628 bytes, text/plain)
2015-08-08 23:12 EDT, Pinkie Pie
no flags Details
File: environ (88 bytes, text/plain)
2015-08-08 23:12 EDT, Pinkie Pie
no flags Details

  None (edit)
Description Pinkie Pie 2015-08-08 23:12:06 EDT
Version-Release number of selected component:
policycoreutils-gui-2.4-8.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 /usr/share/system-config-selinux/selinux_server.py
executable:     /usr/share/system-config-selinux/selinux_server.py
kernel:         4.2.0-0.rc4.git0.1.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
selinux_server.py:6:<module>:ImportError: No module named 'gobject'

Traceback (most recent call last):
  File "/usr/share/system-config-selinux/selinux_server.py", line 6, in <module>
    import gobject
ImportError: No module named 'gobject'

Local variables in innermost frame:
__loader__: <_frozen_importlib.SourceFileLoader object at 0x7f478e5aaf60>
__doc__: None
__package__: None
__builtins__: <module 'builtins' (built-in)>
__spec__: None
dbus: <module 'dbus' from '/usr/lib64/python3.4/site-packages/dbus/__init__.py'>
__name__: '__main__'
__file__: '/usr/share/system-config-selinux/selinux_server.py'
__cached__: None
Comment 1 Pinkie Pie 2015-08-08 23:12:09 EDT
Created attachment 1060678 [details]
File: backtrace
Comment 2 Pinkie Pie 2015-08-08 23:12:10 EDT
Created attachment 1060679 [details]
File: environ
Comment 3 Petr Lautrbach 2015-08-11 09:20:51 EDT
Thanks for the report.

It seems to be related to python3 port. We'll try to resolve the issue until Fedora 23 Beta.
Comment 4 Pinkie Pie 2015-08-11 11:01:05 EDT
Is it also the cause of: 

[pinkie@linux ~]$ sealert
Traceback (most recent call last):
  File "/usr/bin/sealert", line 50, in <module>
    from setroubleshoot.util import get_identity, load_plugins, log_debug
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/util.py", line 291, in <module>
    from sepolicy import get_all_file_types
ImportError: No module named sepolicy

?
Comment 5 Petr Lautrbach 2015-08-13 12:07:33 EDT
There are two different issue. The original report should be fixed by the latest policycoreutils-2.4-9.fc23 update.

The problem from #c4 is due to wrong dependencies in not-yet-ported-to-python3 sealert. setroubleshoot-server requires policycoreutils-python-utils requires python3 policycoreutils while it's still python2. There'll be an update of setroubleshoot rewritten for python3 soon. There's already a pull request for that on github [1] and according to my testing, it works reasonably. 

[1] https://github.com/fedora-selinux/setroubleshoot/pull/8
Comment 6 Petr Lautrbach 2015-08-13 12:22:26 EDT
setroubleshoot testing builds are available in my COPR repository https://copr.fedoraproject.org/coprs/plautrba/setroubleshoot/
Comment 7 Pinkie Pie 2015-08-14 03:59:16 EDT
Ah ok, thanks for the infos.
Comment 8 Petr Lautrbach 2015-09-02 02:22:05 EDT
I believe that this issue is already solved by the latest update. If the problem persists feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.