Bug 1251752 - Self Hosted Engine does not start on FC storage
Self Hosted Engine does not start on FC storage
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
---
All Linux
high Severity high (vote)
: ovirt-3.6.0-rc
: 1.3.0
Assigned To: Simone Tiraboschi
Elad
: Reopened
: 1242554 (view as bug list)
Depends On: 1258465
Blocks: 1036731 1153278
  Show dependency treegraph
 
Reported: 2015-08-09 11:59 EDT by Jacek Kowalski
Modified: 2016-02-10 07:56 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 07:56:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
patch for ovirt-hosted-engine-setup (433 bytes, text/plain)
2015-08-09 11:59 EDT, Jacek Kowalski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44306 master MERGED Directly use vdscli to connectStorageServer Never

  None (edit)
Description Jacek Kowalski 2015-08-09 11:59:16 EDT
Created attachment 1060762 [details]
patch for ovirt-hosted-engine-setup

Description of problem:

On oVirt 3.6 Beta, after completing the setup with self hosted engine on Fibre Channel storage, ovirt-ha-agent fails to start the engine.


Version-Release number of selected component (if applicable):

ovirt-hosted-engine-setup-1.3.0-0.0.master.20150729070044.git26149d7.el7.noarch


How reproducible:

always


Steps to Reproduce:

1. Install oVirt hosted engine on FC storage


Actual results:

/var/log/ovirt-hosted-engine-ha/agent.log:
MainThread::WARNING::2015-08-09 16:50:37,349::hosted_engine::581::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_vdsm) Failed to connect storage, waiting '15' seconds before the next attempt


Expected results:

No errors.


Additional info:

The root cause is that command "hosted-engine --connect-storage" (executed by ovirt-ha-agent) fails with error:

Storage type not supported: fc

I have attached a patch for ovirt-hosted-engine-setup which fixes this issue.
Comment 1 Simone Tiraboschi 2015-08-10 06:54:14 EDT
Thanks Jacek,
till last week connectStorageServer on FC device wasn't needed/supported:
https://gerrit.ovirt.org/#/q/status:merged+project:vdsm+branch:master+topic:fc-connect-storage-server
now instead we have too.

I'm already trying to rewrote all that section using vdscli (python lib) instead of vdsClient (external CLI tool):  https://gerrit.ovirt.org/#/c/44306/
Comment 2 Simone Tiraboschi 2015-08-12 09:52:29 EDT
patch 44306 start using vdscli instead of vdsClient on the HA agent whicj is part of the issue.
The connectStorageServer call witch is other part is still missing. So keep it open.
Comment 3 Simone Tiraboschi 2015-08-24 08:15:56 EDT
*** Bug 1242554 has been marked as a duplicate of this bug. ***
Comment 4 Elad 2015-11-08 04:21:14 EST
Hosted-engine starts successfully after deployment over FC.

Verified using:
ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
vdsm-4.17.10.1-0.el7ev.noarch
vdsm-cli-4.17.10.1-0.el7ev.noarch
Comment 5 Sandro Bonazzola 2015-11-27 02:52:03 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.
Comment 6 Simone Tiraboschi 2015-12-17 12:28:19 EST
Please test it again when #1258465 got fixed also for FC.
Comment 7 Elad 2016-01-21 08:03:07 EST
Hosted-engine VM starts successfully while HE is deployed over FC. The HE SD gets imported with the VM successfully and the VM is manageable in the engine.


Tested using:
Host:

ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
libgovirt-0.3.3-1.el7_2.1.x86_64
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-host-deploy-1.4.1-1.el7ev.noarch
ovirt-setup-lib-1.0.1-1.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
vdsm-jsonrpc-4.17.18-0.el7ev.noarch
vdsm-python-4.17.18-0.el7ev.noarch
vdsm-hook-vmfex-dev-4.17.18-0.el7ev.noarch
vdsm-cli-4.17.18-0.el7ev.noarch
vdsm-yajsonrpc-4.17.18-0.el7ev.noarch
vdsm-xmlrpc-4.17.18-0.el7ev.noarch
vdsm-4.17.18-0.el7ev.noarch
vdsm-infra-4.17.18-0.el7ev.noarch


Engine:

ovirt-engine-extension-aaa-jdbc-1.0.5-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.2.6-0.1.el6.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.6.2.6-0.1.el6.noarch
ovirt-setup-lib-1.0.1-1.el6ev.noarch
rhevm-setup-plugin-websocket-proxy-3.6.2.6-0.1.el6.noarch
rhevm-vmconsole-proxy-helper-3.6.2.6-0.1.el6.noarch
rhevm-spice-client-x86-msi-3.6-6.el6.noarch
rhevm-lib-3.6.2.6-0.1.el6.noarch
rhevm-cli-3.6.0.0-1.el6ev.noarch
rhevm-webadmin-portal-3.6.2.6-0.1.el6.noarch
rhevm-tools-3.6.2.6-0.1.el6.noarch
rhevm-iso-uploader-3.6.0-1.el6ev.noarch
rhevm-doc-3.6.0-2.el6eng.noarch
rhevm-backend-3.6.2.6-0.1.el6.noarch
rhevm-setup-3.6.2.6-0.1.el6.noarch
rhevm-spice-client-x64-cab-3.6-6.el6.noarch
rhevm-userportal-3.6.2.6-0.1.el6.noarch
rhevm-image-uploader-3.6.0-1.el6ev.noarch
rhevm-branding-rhev-3.6.0-3.el6ev.noarch
rhevm-sdk-python-3.6.2.1-1.el6ev.noarch
rhevm-log-collector-3.6.0-1.el6ev.noarch
rhevm-dependencies-3.6.0-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-common-3.6.2.6-0.1.el6.noarch
rhevm-dbscripts-3.6.2.6-0.1.el6.noarch
rhevm-setup-plugins-3.6.1-2.el6ev.noarch
rhevm-spice-client-x64-msi-3.6-6.el6.noarch
rhevm-restapi-3.6.2.6-0.1.el6.noarch
rhevm-setup-plugin-ovirt-engine-3.6.2.6-0.1.el6.noarch
rhevm-3.6.2.6-0.1.el6.noarch
rhevm-setup-base-3.6.2.6-0.1.el6.noarch
rhevm-extensions-api-impl-3.6.2.6-0.1.el6.noarch
rhevm-websocket-proxy-3.6.2.6-0.1.el6.noarch
rhevm-setup-plugin-vmconsole-proxy-helper-3.6.2.6-0.1.el6.noarch
rhevm-spice-client-x86-cab-3.6-6.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.