Bug 1251812 - Stage Candlepin WEBUI display Oops! when run virt-who with 100 guests in host
Summary: Stage Candlepin WEBUI display Oops! when run virt-who with 100 guests in host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Candlepin
Version: Unspecified
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: xingge
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-10 03:48 UTC by dazhang
Modified: 2019-09-25 21:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:17:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
WEBUI display Oops! when run virt-who with 100 guests in host (173.49 KB, image/png)
2015-08-10 03:48 UTC, dazhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description dazhang 2015-08-10 03:48:05 UTC
Created attachment 1060927 [details]
WEBUI display Oops! when run virt-who with 100 guests in host

Description of problem:
WEBUI display Oops! when run virt-who with 100 guests in host

Version-Release number of selected component (if applicable):
RHEL-7.2-20150720.0-Server-x86_64(KVM) against Stage Candlepin
subscription-manager-1.15.6-1.el7.x86_64
subscription-manager-gui-1.15.6-1.el7.x86_64
virt-who-0.14-2.el7.noarch
python-rhsm-1.15.3-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. prepare host with large number(e.g >100) of guests in it

2.configure virt-who, enable debugging
 # vi /etc/sysconfig/virt-who
   VIRTWHO_BACKGROUND=1
   VIRTWHO_DEBUG=1
   VIRTWHO_INTERVAL=5

3. restart virt-who service
 # service virt-who restart

4. check host/guest info in WEB UI, click the host Units item , WEB UI display Oops! 


Actual results:
WEBUI display Oops! as shown below when run virt-who with 100 guests in host.
Something completely unexpected just occurred.

More details, please refer to the attachment. 

When the guests change to < 20, click the Units item, can show the detail page normally.


Expected results:
In web UI, there should be no errors and host/guest info should correct

Additional info:

Comment 2 Eko 2015-09-08 07:11:09 UTC
this issue can't be duplicated in 7.2-20150904.0

Comment 6 errata-xmlrpc 2016-07-27 09:17:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.