Bug 1251844 - [Debian] vdsm : Depends: linux-image but it is not installable
[Debian] vdsm : Depends: linux-image but it is not installable
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Packaging.deb (Show other bugs)
4.17.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.1
: 4.17.11
Assigned To: Sandro Bonazzola
Pavel Stehlik
:
Depends On:
Blocks: 1163069
  Show dependency treegraph
 
Reported: 2015-08-10 02:45 EDT by Sandro Bonazzola
Modified: 2016-02-10 03:49 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:49:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑3.6.z?
ylavi: planning_ack+
dfediuck: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49257 None None None Never

  None (edit)
Description Sandro Bonazzola 2015-08-10 02:45:38 EDT
apt-get install vdsm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vdsm : Depends: linux-image but it is not installable
E: Unable to correct problems, you have held broken packages.
Comment 1 Sandro Bonazzola 2015-08-10 02:53:47 EDT
weird issue is that it looks like the package is already installed:

# aptitude search linux-image
i A linux-image-3.16.0-4-amd64          - Linux 3.16 for 64-bit PCs                                                                                  
p   linux-image-3.16.0-4-amd64-dbg      - Debugging symbols for Linux 3.16.0-4-amd64                                                                 
i   linux-image-amd64                   - Linux for 64-bit PCs (meta-package)                                                                        
p   linux-image-amd64-dbg               - Debugging symbols for Linux amd64 configuration (meta-package)
Comment 2 Sandro Bonazzola 2015-08-10 02:55:29 EDT
"aptitude install vdsm" gives a better explanation:
The following packages have unmet dependencies:
 vdsm : Depends: linux-image which is a virtual package.
Comment 3 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:51 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Sandro Bonazzola 2015-09-22 03:50:14 EDT
Dropping blocker. Debian support is best effort. Postponed to 3.6.1
Dan, plans for reviewing the posted patch?
Comment 5 Red Hat Bugzilla Rules Engine 2015-09-22 03:50:17 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 6 Yaniv Lavi 2015-09-22 04:06:12 EDT
(In reply to Sandro Bonazzola from comment #4)
> Dropping blocker. Debian support is best effort. Postponed to 3.6.1
> Dan, plans for reviewing the posted patch?

Dropping the test blocker then.
Comment 7 Sandro Bonazzola 2015-10-01 03:43:43 EDT
Yaniv B. Simone posted patches, please review / merge.
Comment 8 Red Hat Bugzilla Rules Engine 2015-10-19 06:52:33 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Yaniv Lavi 2015-10-29 08:26:51 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 10 Pavel Stehlik 2016-02-10 03:49:50 EST
Closing older BZs, if still happened, please reopen.

Note You need to log in before you can comment on or make changes to this bug.