This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251880 - [abrt] general protection fault in __kmalloc_node_track_caller
[abrt] general protection fault in __kmalloc_node_track_caller
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:92480dc9b5f2e14dceef4e088a2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 04:23 EDT by info@kobaltwit.be
Modified: 2015-08-19 04:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: kernel-4.1.5-100.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 04:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (66.86 KB, text/plain)
2015-08-10 04:23 EDT, info@kobaltwit.be
no flags Details

  None (edit)
Description info@kobaltwit.be 2015-08-10 04:23:49 EDT
Additional info:
reporter:       libreport-2.6.2
general protection fault: 0000 [#1] SMP 
Modules linked in: hidp rpcsec_gss_krb5 auth_rpcgss nfsv4 dns_resolver nfs lockd grace sunrpc fscache rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_broute bridge ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw bnep ppdev kvm_amd kvm snd_hda_codec_hdmi joydev btusb snd_hda_codec_realtek btbcm btintel bluetooth snd_hda_codec_generic snd_hda_intel gspca_zc3xx snd_usb_audio snd_hda_controller snd_hda_codec gspca_main videodev
 snd_usbmidi_lib snd_hda_core media snd_rawmidi snd_hwdep rfkill snd_seq snd_seq_device snd_pcm k10temp edac_core edac_mce_amd sp5100_tco i2c_piix4 snd_timer snd parport_pc soundcore parport shpchp acpi_cpufreq binfmt_misc ata_generic pata_acpi uas usb_storage hid_plantronics nouveau video mxm_wmi i2c_algo_bit drm_kms_helper firewire_ohci serio_raw firewire_core sata_sil crc_itu_t ttm pata_atiixp 8021q garp drm stp llc mrp r8169 mii wmi
CPU: 2 PID: 657 Comm: kworker/u13:1 Not tainted 4.1.3-201.fc22.x86_64 #1
Hardware name: MICRO-STAR INTERNATIONAL CO.,LTD MS-7376/K9A2 Platinum (MS-7376), BIOS V1.B0 06/21/2010
Workqueue: hci0 hci_rx_work [bluetooth]
task: ffff8801ada54f00 ti: ffff8801af158000 task.ti: ffff8801af158000
RIP: 0010:[<ffffffff8120f074>]  [<ffffffff8120f074>] __kmalloc_node_track_caller+0x1c4/0x320
RSP: 0018:ffff8801af15b848  EFLAGS: 00010246
RAX: 007665647562696c RBX: 00000000000102d0 RCX: ffffffff8166e347
RDX: 00000000000052df RSI: 0000000000000000 RDI: 000000000001ac00
RBP: ffff8801af15b8a8 R08: ffff8801b7c9ac00 R09: ffff8801b1001500
R10: ffff8801af3c8200 R11: 007665647562696c R12: 00000000000102d0
R13: 0000000000000380 R14: 00000000ffffffff R15: ffff8801b1001500
FS:  00007f5099143900(0000) GS:ffff8801b7c80000(0000) knlGS:00000000ec2ffb40
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 000055daecc00288 CR3: 00000000bd349000 CR4: 00000000000007e0
Stack:
 ffff8801af3c8900 ffff880036bc5000 0000000100000229 0000000000000000
 ffff8801af15b888 ffffffff8166e347 0000000000000292 ffff8801af3c8200
 ffff8801af15b91f 00000000000000d0 0000000000000380 00000000ffffffff
Call Trace:
 [<ffffffff8166e347>] ? __alloc_skb+0x87/0x210
 [<ffffffff8166d331>] __kmalloc_reserve.isra.28+0x31/0x90
 [<ffffffff8166e31b>] ? __alloc_skb+0x5b/0x210
 [<ffffffff8166e347>] __alloc_skb+0x87/0x210
 [<ffffffff813b0e43>] kobject_uevent_env+0x433/0x540
 [<ffffffff813b0f5b>] kobject_uevent+0xb/0x10
 [<ffffffff814e7c77>] device_del+0x197/0x270
 [<ffffffff810e4588>] ? __wake_up+0x48/0x60
 [<ffffffff815cb6c7>] __input_unregister_device+0x137/0x160
 [<ffffffff815cb7c5>] input_unregister_device+0x55/0x90
 [<ffffffff81640aaf>] hidinput_disconnect+0x7f/0xb0
 [<ffffffff8163d750>] hid_disconnect+0x80/0x90
 [<ffffffff8163d825>] hid_device_remove+0xc5/0xe0
 [<ffffffff814ec167>] __device_release_driver+0x87/0x120
 [<ffffffff814ec223>] device_release_driver+0x23/0x30
 [<ffffffff814eba98>] bus_remove_device+0x108/0x180
 [<ffffffff814e7c21>] device_del+0x141/0x270
 [<ffffffff8163d8c7>] hid_destroy_device+0x27/0x60
 [<ffffffffa0751b0b>] hidp_session_remove+0x4b/0xb0 [hidp]
 [<ffffffffa04daee0>] l2cap_conn_del+0xb0/0x240 [bluetooth]
 [<ffffffffa04db0b1>] l2cap_disconn_cfm+0x41/0x70 [bluetooth]
 [<ffffffffa04c291d>] hci_event_packet+0x20dd/0x32f0 [bluetooth]
 [<ffffffff810d5c9f>] ? account_entity_dequeue+0xaf/0xd0
 [<ffffffff810d9c01>] ? dequeue_entity+0x31/0x640
 [<ffffffffa04afc48>] hci_rx_work+0x1c8/0x410 [bluetooth]
 [<ffffffff810db92c>] ? put_prev_task_fair+0x2c/0x40
 [<ffffffff810baa6b>] process_one_work+0x1bb/0x410
 [<ffffffff810bad13>] worker_thread+0x53/0x480
 [<ffffffff810bacc0>] ? process_one_work+0x410/0x410
 [<ffffffff810c0b88>] kthread+0xd8/0xf0
 [<ffffffff810c0ab0>] ? kthread_worker_fn+0x180/0x180
 [<ffffffff817a1e62>] ret_from_fork+0x42/0x70
 [<ffffffff810c0ab0>] ? kthread_worker_fn+0x180/0x180
Code: 83 c4 38 48 89 d8 5b 41 5c 41 5d 41 5e 41 5f 5d c3 66 0f 1f 44 00 00 49 63 41 20 49 8b 39 4c 01 d8 40 f6 c7 0f 0f 85 2c 01 00 00 <48> 8b 18 48 8d 4a 01 4c 89 d8 65 48 0f c7 0f 0f 94 c0 84 c0 0f 
RIP  [<ffffffff8120f074>] __kmalloc_node_track_caller+0x1c4/0x320
 RSP <ffff8801af15b848>
Comment 1 info@kobaltwit.be 2015-08-10 04:23:53 EDT
Created attachment 1060964 [details]
File: dmesg
Comment 2 info@kobaltwit.be 2015-08-10 04:26:21 EDT
May be a duplicate of bug 1251877. The crash happened on the same system and the backtrace is similar. This abrt report is slightly older and I don't remember the circumstances in which it happened exactly.
Comment 3 Fedora Update System 2015-08-11 20:21:02 EDT
kernel-4.1.5-100.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-4.1.5-100.fc21
Comment 4 Fedora Update System 2015-08-11 20:22:59 EDT
kernel-4.1.5-200.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kernel-4.1.5-200.fc22
Comment 5 Fedora Update System 2015-08-13 12:54:13 EDT
Package kernel-4.1.5-100.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-4.1.5-100.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13391/kernel-4.1.5-100.fc21
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2015-08-19 04:03:59 EDT
kernel-4.1.5-200.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-08-19 04:11:54 EDT
kernel-4.1.5-100.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.