Bug 1251885 - [zh_CN] Unexpected key strings (_P) (_E) in Edit-> Preference dialog.
[zh_CN] Unexpected key strings (_P) (_E) in Edit-> Preference dialog.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-terminal (Show other bugs)
7.2
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Debarshi Ray
QE Internationalization Bugs
: Translation
Depends On:
Blocks: 1313485 1340415
  Show dependency treegraph
 
Reported: 2015-08-10 04:35 EDT by Lijun Li
Modified: 2016-11-03 19:47 EDT (History)
8 users (show)

See Also:
Fixed In Version: gnome-terminal-3.14.3-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:47:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unexpected key strings (_P) (_E) in Preference dialog (51.90 KB, image/png)
2015-08-10 04:36 EDT, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 755756 None None None Never

  None (edit)
Description Lijun Li 2015-08-10 04:35:32 EDT
Description of problem:
[zh_CN] Unexpected key strings (_P) (_E) in Edit-> Preference dialog.

Version-Release number of selected component (if applicable):
gnome-terminal-3.14.3-1.el7.x86_64.rpm 

How reproducible:
100%

Steps to Reproduce:
1. Install latest rhel7.2 build and log in system with zh_CN locale.
2. Run terminal
3. Click Edit->Preference.

Actual results:
[zh_CN] Unexpected key strings (_P) (_E) in Edit-> Preference dialog.

Expected results:
They should be removed.

Additional info:
Please see the attached screen-shot.
Comment 1 Lijun Li 2015-08-10 04:36:50 EDT
Created attachment 1060965 [details]
Unexpected key strings (_P) (_E) in Preference dialog
Comment 3 Matthias Clasen 2015-09-28 14:26:04 EDT
These strings come directly out of the Chinese translation:

#: ../src/preferences.ui.h:5
msgid "Preferences"
msgstr "配置文件首选项(_P)"


#: ../src/preferences.ui.h:18
msgid "Encodings"
msgstr "编码(_E)"


This needs to be fixed in the .po file, ideally upstream. Adding "(_P)" as a suffix only makes sense if the string has a mnemonic underline in it to begin with.
Comment 4 Matthias Clasen 2015-09-28 14:30:44 EDT
I've filed an upstream bug for this issue.
Comment 7 Matthias Clasen 2016-04-05 10:24:52 EDT
Are you going to provide a patch for this ?

If it is sufficient to just take those upstream translations you showed and strip the (_E) from the one that still has it, we can do that ourselves, too.

Just let me know what you prefer
Comment 8 Noriko Mizumoto 2016-04-05 21:04:58 EDT
Hi Matthias

Red Hat Simplified Chinese (zh_CN) translator went through the PO, and suggested me to correct them as below. The translation for "Preferences" needs to be corrected, while "Encodings" looks fine.

msgid "Preferences"
 => 首选项 

msgid "Encodings"
 => 编码
Comment 12 errata-xmlrpc 2016-11-03 19:47:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2167.html

Note You need to log in before you can comment on or make changes to this bug.