This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251926 - WebUI - Deleted Organization appears in the search results just after removal
WebUI - Deleted Organization appears in the search results just after removal
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Ohad Levy
Roman Plevka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 06:15 EDT by Roman Plevka
Modified: 2015-08-14 11:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 11:51:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Plevka 2015-08-10 06:15:01 EDT
Description of problem:
The organization still appears in the search list just after it is being deleted and the 'success notification' has been displayed.

This is probably caused by some time taken by reindexing.

Anyway, the Notification saying that the Organization has been deleted should appear after the removal AND reindexing is done.

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20150806.3

How reproducible:
reproduced with robottelo automated testing.
-every time, the time needed for reindexing varies on the length and encoding of the org name

Steps to Reproduce:
1. Create an organization
2. Upload a manifest for the org (possibly not needed)
3. Create the env. path with 2 environments (possibly not needed)
4. Delete the organization
5. After success notification is displayed, put the name of the org into the search
6. The org is being displayed


Actual results:
The org is being displayed

Expected results:
The org is no longer present in the search results

Additional info:

- Please note, that we're talking about seconds, that means, executing the steps manually won't trigger the issue as the action is being performed too slow.
However, it is always visible in the automated testing.
Comment 1 Bryan Kearney 2015-08-14 11:51:01 EDT
This is due to the fact that deletion is a background task. Since this will quickly be deleted, we do not have plans to address this.

Note You need to log in before you can comment on or make changes to this bug.