Bug 1251937 - Edit host: Can't update host without unavailable options "Host Groups" and "Compute Resources".
Edit host: Can't update host without unavailable options "Host Groups" and "C...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.6
Unspecified Unspecified
high Severity high
: ---
: 3.6.0
Assigned To: Alexander Wels
Karolína Hajná
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 07:16 EDT by Vered Volansky
Modified: 2016-05-19 21:23 EDT (History)
13 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:37:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44678 None None None Never
oVirt gerrit 44691 ovirt-engine-3.6 MERGED frontend: Fix NPE in edit host dialog Never

  None (edit)
Description Vered Volansky 2015-08-10 07:16:51 EDT
Description of problem:
When trying to update a host from (any edit operation), in the Edit dialog, after pressing OK the following happens:
Host Groups and Compute Resources now have too-long underlines, the (empty) combo-boxes become red.
Can't continue with update, there's no tooltip when hovering over the combo-box or the underline.

Version-Release number of selected component (if applicable):
stable branch, commit - 6d8fdd9231be4788898b30059d2a0e8c90593bc2

How reproducible:
100%

Steps to Reproduce:
1. Edit a host
2. Press OK


Actual results:
As described above.

Expected results:
Update successfully.
If there is indeed an issue have a normal underline, tooltip, and some opstions in the combo-boxes.
Comment 1 Michal Skrivanek 2015-08-11 05:27:21 EDT
host dialog is infra, reassigning. 
Curiously, just tried yesterday's master and there seems to be NPE in frontend or something.
So not sure
Comment 2 Karolína Hajná 2015-09-16 08:01:58 EDT
Verified on rhevm-3.6.0-0.15.master.el6.noarch
Comment 3 Sandro Bonazzola 2015-11-04 06:37:56 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.