Bug 1251938 - Left-handed orientation for Wacom tablet not working
Left-handed orientation for Wacom tablet not working
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 07:22 EDT by Tuomas Kuosmanen
Modified: 2016-02-29 06:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 06:38:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomas Kuosmanen 2015-08-10 07:22:48 EDT
Description of problem: The left-handed orientation -button in control -center -> wacom tablet does not work in fedora 22. Worked in 21 though.


Version-Release number of selected component (if applicable): gnome-control-center 3.16.2



How reproducible: always


Steps to Reproduce:
1. open gnome control center and have a wacom tablet plugged in
2. activate "left handed orientation"
3. move pen or touch pointer (I have a Wacom Intuos5 Touch M, so touch events work too)

Actual results: no change in orientation


Expected results: tablet axis should flip so that you can turn it so that the buttons are on the right side (since the pen is on the left hand)


Additional info: 
lsusb -v, in case it helps:

Bus 004 Device 018: ID 056a:0027 Wacom Co., Ltd Intuos5 touch M
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        16
  idVendor           0x056a Wacom Co., Ltd
  idProduct          0x0027 Intuos5 touch M
  bcdDevice            1.07
  iManufacturer           1 
  iProduct                2 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           59
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              498mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      2 Mouse
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     243
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0010  1x 16 bytes
        bInterval               1
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      23
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               2
Comment 1 Olivier Samyn 2015-08-24 04:28:33 EDT
Got the same problem with a Bamboo Pen tablet.

usb info:
056a:00dd Wacom Co., Ltd Bamboo Pen (CTL-470)

I get the problem both on my laptop and on my desktop; both have been updated from F21 to F22 via fedup.

No error shows up in the journal.

Note that other options, like reassigning buttons, works.
Comment 2 Tuomas Kuosmanen 2015-08-24 06:20:41 EDT
My memory says it worked in F21, but broke in 22.
Comment 3 Olivier Samyn 2015-09-07 07:10:59 EDT
I just tried to find a workaround. The best option I ave for now is to use xsetwacom so set the options manually.

So, in a terminal just launch (for the bamboo tablet):
xsetwacom --set "Wacom Bamboo Connect Pen stylus" Rotate half 

For other devices, you should adapt the device name woth one reported by:
xsetwacom --list devices


As xsetwacom is working; it seems to me the problem is in gnome-settings-daemon (or the way it communicates with the xorg driver).
Comment 4 Olivier Samyn 2015-11-06 07:45:07 EST
I just updated to fedora 23 via dnf system-upgrade and still have the same problem.
Comment 5 Tuomas Kuosmanen 2016-02-26 02:40:25 EST
Since I got a new cc: notification for this bug (hi! :-)) I figured I'd check if the problem still is like described.

Now, it looks like the left-handed orientation works for the *stylus and eraser*, but not for the finger touch part. Olivier, can you verify if your case is the same?

This is Fedora23 with roughly the latest updates.

When I do:
  xsetwacom --set "Wacom Intuos5 touch M Finger touch" Rotate half

..it also rotates the finger touch. So looks like the xsetwacom part is working correctly, but the Gnome control panel is probably not recognizing the "Finger touch" device as something it should deal with.
Comment 6 Tuomas Kuosmanen 2016-02-29 03:04:38 EST
I am shooting a bit in the dark here, but hopefully this helps. Apologies if this information is redundant.

tigert@crypt0nite:~$ xinput 
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech T620                           	id=9	[slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse         	id=10	[slave  pointer  (2)]
⎜   ↳ Wacom Intuos5 touch M Pen stylus        	id=13	[slave  pointer  (2)]
⎜   ↳ Wacom Intuos5 touch M Pad pad           	id=14	[slave  pointer  (2)]
⎜   ↳ Wacom Intuos5 touch M Finger touch      	id=15	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=18	[slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                   	id=19	[slave  pointer  (2)]
⎜   ↳ Wacom Intuos5 touch M Pen eraser        	id=21	[slave  pointer  (2)]
⎜   ↳ Wacom Intuos5 touch M Pen cursor        	id=22	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
    ↳ Yubico Yubico Yubikey II                	id=11	[slave  keyboard (3)]
    ↳ Integrated Camera                       	id=12	[slave  keyboard (3)]
    ↳ HID 046a:0011                           	id=16	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=17	[slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                  	id=20	[slave  keyboard (3)]

tigert@crypt0nite:~$ xinput list  15
Wacom Intuos5 touch M Finger touch      	id=15	[slave  pointer  (2)]
	Reporting 9 classes:
		Class originated from: 15. Type: XIButtonClass
		Buttons supported: 7
		Button labels: None None None None None None None
		Button state:
		Class originated from: 15. Type: XIKeyClass
		Keycodes supported: 248
		Class originated from: 15. Type: XIValuatorClass
		Detail for Valuator 0:
		  Label: Abs X
		  Range: 0.000000 - 4096.000000
		  Resolution: 18000 units/m
		  Mode: absolute
		  Current value: 0.000000
		Class originated from: 15. Type: XIValuatorClass
		Detail for Valuator 1:
		  Label: Abs Y
		  Range: 0.000000 - 4096.000000
		  Resolution: 29000 units/m
		  Mode: absolute
		  Current value: 0.000000
		Class originated from: 15. Type: XIValuatorClass
		Detail for Valuator 2:
		  Label: Abs Pressure
		  Range: 0.000000 - 2048.000000
		  Resolution: 1 units/m
		  Mode: absolute
		  Current value: 0.000000
		Class originated from: 15. Type: XIValuatorClass
		Detail for Valuator 3:
		  Label: None
		  Range: 0.000000 - 1.000000
		  Resolution: 1 units/m
		  Mode: absolute
		  Current value: 0.000000
		Class originated from: 15. Type: XIValuatorClass
		Detail for Valuator 4:
		  Label: None
		  Range: 0.000000 - 1.000000
		  Resolution: 1 units/m
		  Mode: absolute
		  Current value: 0.000000
		Class originated from: 15. Type: XIValuatorClass
		Detail for Valuator 5:
		  Label: None
		  Range: 0.000000 - 1.000000
		  Resolution: 1 units/m
		  Mode: absolute
		  Current value: 0.000000
		Class originated from: 15. Type: XITouchClass
		Touch mode: dependent
		Max number of touches: 16

Watching the properties on the touch device:

tigert@crypt0nite:~$ xinput watch-props 15
Device 'Wacom Intuos5 touch M Finger touch':
	Device Enabled (138):	1
	Coordinate Transformation Matrix (140):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (271):	0
	Device Accel Constant Deceleration (272):	1.000000
	Device Accel Adaptive Deceleration (273):	1.000000
	Device Accel Velocity Scaling (274):	10.000000
	Device Node (259):	"/dev/input/event21"
	Wacom Tablet Area (300):	0, 0, 4096, 4096
	Wacom Rotation (301):	0
	Wacom Pressurecurve (302):	0, 0, 100, 100
	Wacom Serial IDs (303):	39, 1, 3, 0, 0
	Wacom Serial ID binding (304):	0
	Wacom Pressure Threshold (305):	0
	Wacom Sample and Suppress (306):	2, 4
	Wacom Enable Touch (307):	1
	Wacom Enable Touch Gesture (309):	1
	Wacom Touch Gesture Parameters (310):	180, 80, 250
	Wacom Tool Type (311):	"TOUCH" (337)
	Wacom Button Actions (312):	"Wacom button action 0" (313), "Wacom button action 1" (314), "Wacom button action 2" (315)
	Wacom button action 0 (313):	1572865
	Wacom button action 1 (314):	1572866
	Wacom button action 2 (315):	1572867
	Device Product ID (258):	1386, 39
	Wacom Debug Levels (319):	0, 0

Doing the 
  xsetwacom --set "Wacom Intuos5 touch M Finger touch" Rotate half
in another terminal:

Property 'Wacom Rotation' changed.
	Wacom Rotation (301):	3

Hope this helps!
Comment 7 Olivier Samyn 2016-02-29 06:11:30 EST
Sorry for the late answer, form me it works since some update in January if I remember correctly.

And as my bamboo tablet is the most basic version, I can only test the stylus part (no eraser nor touch available).
Comment 8 Tuomas Kuosmanen 2016-02-29 06:38:26 EST
Well, now that you mention it. I guess I had an update as well and yes, it does work indeed.

Sweet. Thanks, sorry about the spam. Closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.