Bug 1251946 - [engine-setup][docker] engine configuration fails on missing rabbit-mq image
[engine-setup][docker] engine configuration fails on missing rabbit-mq image
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.Engine (Show other bugs)
---
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Sandro Bonazzola
Gonza
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 07:49 EDT by Piotr Kliczewski
Modified: 2015-11-27 02:57 EST (History)
9 users (show)

See Also:
Fixed In Version: 3.6.0-11
Doc Type: Bug Fix
Doc Text:
Cause: kollaglue project dropped "latest" tag Consequence: docker images couldn't be downloaded anymore Fix: moved to kilo release tag Result: docker images are now pulled from the stable kilo release instead of from the latest tag.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:57:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine setup log (403.72 KB, text/plain)
2015-08-10 07:49 EDT, Piotr Kliczewski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45186 master MERGED packaging: setup: docker: move from latest to kilo Never
oVirt gerrit 45450 ovirt-engine-3.6 MERGED packaging: setup: docker: move from latest to kilo Never

  None (edit)
Description Piotr Kliczewski 2015-08-10 07:49:17 EDT
Created attachment 1061014 [details]
engine setup log

Description of problem:

I attempted to install new enigne on both rhel66 and centos7 when running engine-setup both configuration steps failed due to:

[ ERROR ] Failed to execute stage 'Misc configuration': Unable to pull image kollaglue/centos-rdo-rabbitmq:latest: Tag latest not found in repository docker.io/kollaglue/centos-rdo-rabbitmq


Version-Release number of selected component (if applicable):
3.6.0 BETA


How reproducible:

Steps to Reproduce:
1. Install ovirt-engine from 3.6 pre repo
2. run setup-engine
3.

Actual results:
Setup process fails with above message.


Expected results:
Setup process successful

Additional info:
Comment 1 Sandro Bonazzola 2015-08-21 08:00:59 EDT
Need to update http://www.ovirt.org/CinderGlance_Docker_Integration as well.
Comment 2 Gonza 2015-11-26 11:38:13 EST
Verified with:
ovirt-engine-3.6.2-0.0.master.20151124181807.git6d4897e.fc22.noarch

ovirt-engine successfully installed.
Comment 3 Sandro Bonazzola 2015-11-27 02:57:17 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.