This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251949 - spacecmd problems with "++" in package Name (ERROR: multiple repeat)
spacecmd problems with "++" in package Name (ERROR: multiple repeat)
Status: CLOSED WONTFIX
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Gajdusek
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2015-08-10 07:56 EDT by Klaas Demter
Modified: 2017-09-28 14:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-10 05:11:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaas Demter 2015-08-10 07:56:03 EDT
Description of problem:
I'm trying to remove a package using spacecmd and its not working


Version-Release number of selected component (if applicable):
root@spacewalk [0] rhn # rpm -qa|grep spacecmd
spacecmd-2.3.20-1.el6.noarch


How reproducible:
# spacecmd softwarechannel_removepackages channel gcc-c++-4.4.7-4.el6.x86_64
INFO: Connected to https://localhost/rpc/api as admin
ERROR: multiple repeat

to make sure its no bash issue I also tried from within spacecmd
# spacecmd -u admin
Welcome to spacecmd, a command-line interface to Spacewalk.

Type: 'help' for a list of commands
      'help <cmd>' for command-specific help
      'quit' to quit

INFO: Connected to https://localhost/rpc/api as admin
spacecmd {SSM:0}> 
spacecmd {SSM:0}> softwarechannel_removepackages channel gcc-c++-4.4.7-4.el6.x86_64
ERROR: multiple repeat

I also tried various ways I could think of to escape the package name but without success

Steps to Reproduce:
1. run spacecmd softwarechannel_removepackages channel gcc-c++-4.4.7-4.el6.x86_64


Actual results:
ERROR: multiple repeat

Expected results:
delete Package

Additional info:
Comment 1 Jan Dobes 2015-09-09 11:32:50 EDT
There is probably some double escaping in code.

# spacecmd softwarechannel_removepackages channel gcc-c\\+\\+-4.4.7-4.el6.x86_64

This should work.
Comment 2 Ondrej Gajdusek 2016-09-06 08:20:41 EDT
repaired in commit f1d48f0702c010eca967d727eda3887d11270745 in spacewalk/master
Comment 3 Ondrej Gajdusek 2016-11-10 05:11:03 EST
This MULTILPE REPEAT error has been raised in due to that the function expects regexes as input. Actually here is no way to fix it by logical way. User must escape the regexp himself as in many tools which are using regexps.
Comment 4 Ondrej Gajdusek 2016-11-10 05:12:41 EST
Reverted in spacewalk.git 71aff902e6464d94dc7775c634a2139c156c945b.
Comment 5 Eric Herget 2017-09-28 14:11:47 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.