Bug 125196 - network card detection order backwards from FC1
Summary: network card detection order backwards from FC1
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-release (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike McLean
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-03 15:41 UTC by Dax Kelson
Modified: 2014-03-17 02:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 18:33:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2004-06-03 15:41:25 UTC
Description of problem:

I have a classroom full of Dell Dimension 4600 computers. They have
the onboard Intel 100Mb nic (e100 driver) and a 3COM 3c95x in a PCI slot.

In RHL9, RHEL3, FC1 (and SUSE LINUX 9.0 and 9.1):

eth0 -> 3c59x
eth1 -> e100

In FC2, it is the oposite:

eth0 -> e100
eth1 -> 3c59x

This causes us lots of hassles as we run Linux classes in here on a
variety of Linux distributions, and having to specially handle FC2 is
a big pain.

When installing FC2, switch to ALT-F2 you see:

modules to insert mii e100 3c59x libata ata_piix
loaded mii from /modules/modules.cgz
loaded e100 from /modules/modules.cgz
loaded 3c59x from /modules/modules.cgz
loaded libata from /modules/modules.cgz
loaded ata_piix from /modules/modules.cgz
inserted /tmp/mii.ko
inserted /tmp/e100.ko
inserted /tmp/3c59x.ko
inserted /tmp/libata.ko
inserted /tmp/ata_piix.ko

Comment 1 Jeremy Katz 2004-06-04 06:00:37 UTC
This is probably due to ACPI vs not if I had to make a wild guess...

Comment 2 Arjan van de Ven 2004-06-04 07:18:29 UTC
most likely yes. "native" probe order and acpi bios probe order my be
different... not a lot we can do really other than not using acpi to
probe which sounds like a step backwards

Comment 3 Barry K. Nathan 2004-06-14 21:47:14 UTC
This would be a good thing to mention in the RHEL4 release notes, when
that time comes...


Note You need to log in before you can comment on or make changes to this bug.