Bug 1251975 - [Debian] cpopen fails unit testing on testUmaskChange
[Debian] cpopen fails unit testing on testUmaskChange
Status: CLOSED WONTFIX
Product: ovirt-distribution
Classification: oVirt
Component: python-cpopen (Show other bugs)
python-cpopen-1.4.0
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-4.3.0
: ---
Assigned To: Milan Zamazal
Gil Klein
:
Depends On:
Blocks: 1163069
  Show dependency treegraph
 
Reported: 2015-08-10 08:42 EDT by Sandro Bonazzola
Modified: 2018-03-27 03:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-27 03:27:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: External
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.3?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2015-08-10 08:42:06 EDT
======================================================================
ERROR: testUmaskChange (tests.TestCPopen)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/sbonazzo/cpopen/tests/tests.py", line 188, in testUmaskChange
    p = CPopen(['umask'], childUmask=0o007)
  File "../build/lib.linux-x86_64-2.7/cpopen/__init__.py", line 52, in __init__
    stderr=stderr)
  File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "../build/lib.linux-x86_64-2.7/cpopen/__init__.py", line 69, in _execute_child_v276
    errread, errwrite,
  File "../build/lib.linux-x86_64-2.7/cpopen/__init__.py", line 89, in _execute_child_v275
    self._childUmask,
OSError: [Errno 2] No such file or directory

----------------------------------------------------------------------
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:54:49 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-26 06:30:44 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Yaniv Lavi 2015-10-29 08:28:17 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 4 Yaniv Bronhaim 2015-11-04 11:20:07 EST
can be that umask does not exist in your env? should be /usr/bin/umask .. Simone can you check it please? its part of the basic bash package
Comment 5 Sandro Bonazzola 2015-11-25 12:50:01 EST
umask is not a program in debian, it's a bash builtin. note that also in fedora /usr/bin/umask is just:

$ cat /usr/bin/umask 
#!/bin/sh
builtin umask "$@"

please use something like true ( /bin/true in debian, /usr/bin/true in fedora )
Comment 6 Sandro Bonazzola 2016-03-11 03:22:29 EST
Moving to Milan since he's porting vdsm to Debian
Comment 7 Sandro Bonazzola 2016-05-02 06:02:07 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 8 Yaniv Lavi 2016-05-23 09:17:42 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 9 Yaniv Lavi 2016-05-23 09:21:40 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 10 Milan Zamazal 2018-03-21 12:35:48 EDT
I don't think anybody cares about using Debian hosts anymore and I've abandoned my Debian work for that reason long time ago. So I suggest closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.