Bug 1252061 - rhev-h might restore its management network on every reboot
rhev-h might restore its management network on every reboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.4
x86_64 Linux
unspecified Severity medium
: ovirt-3.5.5
: 3.5.5
Assigned To: Ido Barkan
Michael Burman
network
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 11:21 EDT by Ido Barkan
Modified: 2016-02-10 14:16 EST (History)
12 users (show)

See Also:
Fixed In Version: vdsm-4.16.27-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 17:47:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44613 None None None Never
Red Hat Product Errata RHBA-2015:1937 normal SHIPPED_LIVE vdsm 3.5.5 - bug fix and enhancement update 2015-10-26 21:47:38 EDT

  None (edit)
Description Ido Barkan 2015-08-10 11:21:16 EDT
Description of problem:
If a rhev-h host is registered in engine via tui, a management network restoration will happen on each successive reboot although the network was not changed.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. register a node on an engine (via tui) in 3.5.3.
2. upgrade to 3.5.4
3. reboot

Actual results:
VDSM will restore the management network

Expected results:
no network should be restored since in 3.5.4 VDSM does not restore networks that are identical to their persisted configuration.

Additional info:
This is a regression in 3.5.4. until 3.5.4, the management network was the only network configured with ONBOOT=yes. Now, although all the networks are configured that way, VDSM will insist on reconfiguring it on every boot. If, in addition, this network shares a nic with another network (may it be used for storage, migration etc.) will also be disconnected during this restoration.
Comment 1 Michael Burman 2015-10-06 10:55:36 EDT
Verified on - 3.5.5-0.1.el6ev with -->
vdsm-4.16.27-1
rhev-hypervisor6-6.7-20150917.0
rhev-hypervisor7-7.1-20150917.0
Comment 3 errata-xmlrpc 2015-10-26 17:47:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1937.html

Note You need to log in before you can comment on or make changes to this bug.