Bug 1252063 - rhevm-log-collector: drop sos2 / rhel < 6.7 support
rhevm-log-collector: drop sos2 / rhel < 6.7 support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-log-collector (Show other bugs)
3.5.5
Unspecified Unspecified
high Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Sandro Bonazzola
Gonza
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 11:22 EDT by Sandro Bonazzola
Modified: 2016-03-09 15:00 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The rhevm-log-collector packages have been updated and now require sos 3 or above, which is shipped in Red Hat Enterprise Linux 6.7.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 15:00:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44623 master MERGED sos: drop sos 2 build support Never
oVirt gerrit 45171 ovirt-log-collector-3.6 MERGED sos: drop sos 2 build support Never
Red Hat Product Errata RHEA-2016:0392 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2016-03-09 19:19:00 EST

  None (edit)
Description Sandro Bonazzola 2015-08-10 11:22:18 EDT
RHEL 6.7 now ships sos 3 and rhevm-log-collector in 3.5.3 and 3.5.4 supported the upgrade from RHEL 6.6 by splitting the sos plugins in a separate sub package.

In 3.5.5 we should drop the sub-package and require sos >= 3.
Comment 10 Gonza 2015-09-14 07:08:17 EDT
Verified with:
Red Hat Enterprise Linux Server release 6.7 (Santiago)
rhevm-3.6.0-0.12.master.el6.noarch
rhevm-log-collector-3.6.0-0.3.beta.git4e192b9.el6ev.noarch
sos-3.2-28.el6.noarch

# rpm -q --requires rhevm-log-collector
/usr/bin/python  
config(rhevm-log-collector) = 3.6.0-0.3.beta.git4e192b9.el6ev
logrotate  
openssh-clients  
python  
python(abi) = 2.6
python-dateutil  
python-lxml  
rhevm-lib  
rhevm-sdk-python >= 3.6.0.0
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
sos  
rpmlib(PayloadIsXz) <= 5.2-1
Comment 13 errata-xmlrpc 2016-03-09 15:00:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0392.html

Note You need to log in before you can comment on or make changes to this bug.